19.0.0 is not a valid SDK version

#1

I am using expo sdkVersion 19.0.0. When I build using below command:
exp build:android --release-channel prod-vx.x
Build will get complete. But when I install on android device it gives below error:

19.0.0 is not a valid SDK version. Options are 26.0.0, 25.0.0, 24.0.0, 23.0.0, 22.0.0, 21.0.0, 20.0.0, UNVERSIONED.

Please response ASAP. I have to build for new release.

#2

I guess it’s because they just released Expo SDK 26 and dropped SDK 19 support.
Try upgrade to 25 or 26.

#3

It seems they have upgrade notes from v24.0.0 to 25.0.0.
I am searching document for to upgrade from v19.0.0 to v25.0.0.
Do you know where I can find it?

#4

Hey @anil,

As @alanlanglois mentioned, with the release of SDK26 we dropped SDK19 support. Your standalone app will still work as expected but to continue development such as creating a new build, you’ll have to update to a newer SDK version. I’d recommend SDK26 so you don’t have to worry about updating again for a while–although each release makes the Expo SDK better so it’s also a good idea to stay on top of updates.

Cheers,

Adam

#5

Here are the upgrade notes starting at 19 -> 20: https://blog.expo.io/expo-sdk-v20-0-0-is-now-available-79f84232a9d1

Medium makes it hard to find older posts so just google “expo sdk 21” after this and you should find Brent’s upgrade blog posts.

#6

Thanks @adamjnav,
It means these is no direct upgrade from v19.0.0 to v26.0.0?

To upgrade from v19.0.0 to v26.0.0 I have to follow each change as per guidenace i.e.
v19.0.0 to v20.0.0
then
v20.0.0 to v21.0.0
then
v21.0.0 to v22.0.0
then
v22.0.0 to v23.0.0
then
v23.0.0 to v24.0.0
then
v24.0.0 to v25.0.0
then
v25.0.0 to v26.0.0?

#7

No problem @anil!

We recommend to do it one version at a time in case there are any breaking changes between versions. That way you can quickly identify what could be the cause, but there is nothing stopping you from going from SDK19 right to SDK26. But if something breaks, you’ll have to look through all the upgrade notes and try to find out what may be the issue.

#8

Thank you @adamjnav, for reply and describe in a very clear way.

1 Like
closed #9

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.