[2017-10-25] Issues with logging into Expo developer accounts

@faiwilsuc @remoteportal Are either of you able to log into https://expo.io/login successfully? If it asks you to fill in some information (like your name) are you able to do that successfully or do you still get an error and what does it say?

1 Like

Apparently, It looks like my password was changed. So when I try to login with my credentials, it leads to sign up box.
But as you mentioned above, because signup functionality was disabled yet, I can not even signup. Will try to sign up.
I can use my original credentials?

@ide NOW I understand… I thought you meant just log into GitHub, now I understand you to mean sign into expo VIA GitHub as the provider.

I did that… clicked LINK ACCOUNTS, then BRIEFLY saw a “500-like server error message”, then back to this web screen which I think is wrong:


come on im rushing to puslish my app now you gave me this?

Update: We have re-enabled signups for new accounts as well as for developers with existing accounts who were asked to go through the sign-up flow once more.

If you have an existing Expo developer account and were asked to go through the sign-up flow (as a few developers earlier in this thread were), please try again. We recommend logging in through https://expo.io since that is more stateless. Once you’re able to log in through the website, please try again in XDE/exp.

@faiwilsuc @remoteportal @nickawesome We re-enabled signups a few minutes ago. You can try logging in again – we recommend first trying on https://expo.io/login and then trying exp/XDE.

1 Like

@ide Thank you very much for your amazing efforts, i’m all set now.

Ok it works well. thank you for your efforts

1 Like

Cheers! The effort and communication is much appreciated :slight_smile:

1 Like

@jwhscholten Hmm… sorry you ran into an issue. Since you’re able to login successfully I suspect the problem you’re seeing is unrelated to the problem with developer accounts. I’ll follow up with you out of band so we can keep this thread a little more focused on login issues and also get your iOS build in a good place.

@ide : We were stuck for a day, but you were perfectly clear and transparent with us. Many thanks for your investigation and your communcation !


This was a real issue for me - I needed to publish my app for a review today. Which I was able to do finally! Thanks for working so quickly to resolve it and being so transparent.

I see people are reporting here that systems are functioning correctly however we still cannot get an exp build:ios to run. exp start is also telling me it cannot connect.

Main error i get back is

[exp] No currently active or previous builds for this project.
[exp] Checking for existing Apple credentials…
[exp] Error validating credentials. You may need to clear them (with -c) and try again.
[exp] API Response Error: Not authorized.

The same error comes back if i pass the -c flag :frowning:

In my case, “exp logout and exp login” worked.

1 Like

@cookizza, did you get a build ID?
Maybe try logging in and out as well

I When I try to log on to Expo XDE on my desktop it says “invalid_request”. When I try the signing in with GitHub it says “Cannot read property ‘payload’ of null”. Is there a way to fix this?

Expo XDE is no longer maintained, we consolidated XDE and exp into one single tool, expo-cli. See more info in https://blog.expo.io/expo-cli-2-0-released-a7a9c250e99c

Hi I’am getting this error.

expo publish --non-interactive --max-workers 1 --release-channel dev
[23:52:44] Publishing to channel 'dev'...
[23:52:47] You are not authorized to build @xxx@xxx.com/my-app. The username provided under owner may be incorrect or invalid

any ideas about this case guys?