"32.0.0 is not a valid SDK version "

When trying to start a project in React Native using Expo, I am getting am error message saying “32.0.0 is not a valid SDK version”. I have tried updating Node, updating Expo, etc. but nothing has worked thus far. I have also been getting a message that Expo is no longer compatible with my device (Android ).

Hey @cweibel73,

Could you run expo diagnostics in your CLI and paste the output here?

Thanks!

Expo CLI 2.11.6 environment info:
System:
OS: Windows 10
Binaries:
Node: 10.15.2 - C:\node.EXE
Yarn: 1.3.2 - C:\Users\cweibel\AppData\Roaming\npm\yarn.CMD
npm: 6.8.0 - C:\npm.CMD
IDEs:
Android Studio: Version 3.1.0.0 AI-173.4720617

Great, thank you! And are you trying to initialize a project with the expo-cli, or you already have one and you’re trying to start a local server for it (as with expo start)?

I was trying to set up sort of a practice program (I’m very new to React Native) from the command line. I created the directory, but ran into the error message when I attempted to scan the QR code.

I just made another attempt, and this time received a message in the DevTools in the browser that my Expo app was out of date, and that if I uninstalled the app and tried again, a newer version would open on my device. I tried that, but received this error message:

Couldn’t start project on Android: Error running adb: Error running app. Error: Activity not started, unable to resolve Intent { act=android.intent.action.VIEW dat=exp://192.168.0.5:19000 flg=0x10000000 }

Looks like I can’t use Expo on my phone because it is Android 4.4.2 and 5 is the minimum.

I also get the same error.

and this is the result of expo diagnostics :

Expo CLI 3.4.1 environment info:
System:
OS: Windows 10
Binaries:
npm: 6.10.2 - C:\Program Files\nodejs\npm.CMD
IDEs:
Android Studio: Version 3.5.0.0 AI-191.8026.42.35.5791312

and I use expo start like I normally do with 32.0.0

problem solved by re-installing expo client