Amplitude Error for Android

In production many users are receiving the following errors:

Error: The method or property Amplitude.initialize is not available on android, are you sure you’ve linked all the native dependencies properly?

Error: The method or property Amplitude.setUserId is not available on android, are you sure you’ve linked all the native dependencies properly?

SDK: 33.0.5
Managed app using: import { Amplitude } from ‘expo’

Hey @jjt,

The import statements have changed on SDK33 due to most modules being individually packaged rather than imported from an entire expo package. You’ll now want to do import * as Amplitude from 'expo-analytics-amplitude'. https://docs.expo.io/versions/v33.0.0/sdk/amplitude/#api

Cheers,
Adam

Hi Adam,

We tried both. They both give the same error.