Android "build in progress" hangs -- option to cancel?

#1

I started an Android build with “$ exp build:android” ~12 hrs ago.

Expo replied that my app.json file had an issue (a typo in a property), but started building anyways.

I fixed the typo but I’ve been unable to start another build – “Cannot start new build, as there is a build in progress”. Is there a way to cancel the current, doomed, build?

Thanks!

1 Like
#2

Hi! Sorry about that! I cleared the stale build job. Can you try again?

1 Like
#4

i also have this issue… can you help me? :slight_smile: thx

1 Like
#5

I am having the same issue here, it got stuck since the morning and I am not longer able to queue any other Android build.
Could you please help me with that? Thanks!

1 Like
#6

My IOS build is building more than 2 hours, how can i cancel this build and start a new one?

UPD: after waiting one day i create new account, and now Android/IOS apps is build fine.

#7

My build also hang from yesterday night. please help me to clear the stale build job

#8

I have a iOS build that have been “building” for ~24 hours. Can you clear it?

#9

what is the build id?

#10

Thanks for coming back to me @notbrent

I don’t know the ID. The build was started yesterday and the session in which it was started is no more. Can I somehow extract the ID or maybe give you some other info?

#11

Hi, sorry about that. I’ve cleared the errored build job. Can you try again?

#12

Same job as mentioned here iOS build have been hanging for ~30 hours which you’ve fixed already. Thanks🙏

#13

Hi. I have an Android build that have been “building” for many hours. Could you help me?

#14

hi @maxboltik , i’ve cleared our system build queue. You should be able to restart your android builds now. Sorry for the inconvenience.

1 Like
#15

I have a iOS build that have been “building” for ~12 hours. Can you clear it?
BuildID 688bb687-0655-4bda-9585-e8a3ff406808

#16

I have the same issue, can you help me?

#17

you can use build dashboard now for these issues: https://blog.expo.io/introducing-support-for-build-dashboards-apple-two-factor-authentication-81d288a3d03

#18

Hi Expo Team,

I’ve an iOS build that is in process for several hours.
The dashboard ‘Build Logs’ screen has only a spinning Expo logo, and the ‘Cancel’ button is inactive.
Can you check if this is a hung process situation?

my build id is:
b5acfb09-c2bd-4477-accf-5c99364effe6

thanks.

#19

iOS builds are currently being processed at a slower pace. You can follow updates here: https://expo.statuspage.io.

closed #20

This topic was automatically closed after 14 days. New replies are no longer allowed.