Android - libffmpeg -missing codec


#1

I am new to Android. I’ve compiled libffmpeg.so (version 3.4.2) for Android ndk r10e on linux host, including support for x264, freetype2 , libass, liblame, libfonconfig, libogg 1.3.3, libvorbis 1.3.5. I enabled at configure --enable-vorbis. When using libffmpeg.so in an .apk there are some formats that are not be supported: MOV OGG

What option should i enabled, or what library should i still include for these formats?

When I compiled ffmpeg, these were all options I used:

./configure \
--target-os=android \
--cross-prefix="$CROSS_PREFIX" \
--arch="$NDK_ABI" \
--cpu="$CPU" \
--enable-runtime-cpudetect \
--sysroot="$NDK_SYSROOT" \
--enable-pic \
--disable-shared \
--enable-static \
--enable-protocol=file \
--enable-avformat \
--enable-avcodec \
--disable-network \
--enable-zlib \
--enable-libvorbis \
--enable-libx264 \
--enable-libass \
--enable-libfreetype \
--enable-libfribidi \
--enable-libmp3lame \
--enable-fontconfig \
--enable-pthreads \
--disable-stripping \
--disable-linux-perf \
--disable-debug \
--disable-ffserver \
--enable-version3 \
--enable-hardcoded-tables \
--disable-ffplay \
--disable-ffprobe \
--enable-gpl \
--enable-yasm \
--disable-doc \
--pkg-config="${2}/ffmpeg-pkg-config" \
--prefix="${2}/build/${1}" \
--extra-cflags="-I${TOOLCHAIN_PREFIX}/include $CFLAGS" \
--extra-ldflags="-L${TOOLCHAIN_PREFIX}/lib $LDFLAGS" \
--extra-libs="-lpng -lexpat -lm" \
--extra-cxxflags="$CXX_FLAGS" || exit 1

And then I linked all the libraries in libffmpeg.so

make -j${NUMBER_OF_CORES} && make install && 
$PREBUILT/bin/$HOST-ar d libavcodec/libavcodec.a inverse.o &&
$PREBUILT/bin/$HOST-ld -rpath-link=$PLATFORM/usr/lib -L$PLATFORM/usr/lib -soname libffmpeg.so -shared -nostdlib  -z noexecstack -Bsymbolic --whole-archive --no-undefined -o libffmpeg.so libavdevice/libavdevice.a libavformat/libavformat.a libavfilter/libavfilter.a libavcodec/libavcodec.a libswscale/libswscale.a libavutil/libavutil.a libswresample/libswresample.a libpostproc/libpostproc.a ../toolchain-android/lib/libmp3lame.a ../toolchain-android/lib/libx264.a ../toolchain-android/lib/libfreetype.a ../toolchain-android/lib/libexpat.a ../toolchain-android/lib/libfribidi.a ../toolchain-android/lib/libpng16.a ../toolchain-android/lib/libass.a ../toolchain-android/lib/libfontconfig.a ../toolchain-android/lib/libogg.a ../toolchain-android/lib/libvorbis.a ../toolchain-android/lib/libvorbisenc.a ../toolchain-android/lib/libvorbisfile.a -lc -lm -lz -ldl -llog  --dynamic-linker=/system/bin/linker $PREBUILT/lib/gcc/$HOST/4.8/libgcc.a || exit 1

When configuring libvorbis I used: --with-OGG=yes When configuring libmp3lame I used: --with-VORBIS=yes

Thanks & Regards
Camillelola


#2

Hey @camillelola!

Unfortunately at Expo we don’t have any FFMPEG experts, and the last time I worked with the library was in 2013.

You might want to take a look at this: https://ffmpeg.org/ffmpeg.html and ask on their forums! Sorry I can’t be of more help. Good luck :slight_smile:


#3

Hi jimmylee,

Thanks for your response.


closed #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.