Android standalone app crashes on start

Expo CLI 3.17.15 environment info:
System:
OS: macOS 10.15.3
Shell: 5.7.1 - /bin/zsh
Binaries:
Node: 12.14.0 - /usr/local/bin/node
Yarn: 1.21.1 - ~/.yarn/bin/yarn
npm: 6.13.4 - /usr/local/bin/npm
IDEs:
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.4/11E146 - /usr/bin/xcodebuild
npmPackages:
expo: ^37.0.0 => 37.0.4
react: 16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-37.0.0.tar.gz => 0.61.4
react-navigation: 4.0.10 => 4.0.10
npmGlobalPackages:
expo-cli: 3.17.15

Hello,

Today I did a little update on my app and generated the Android standalone build via expo build:android . When I tried that build on my phone, the app crashed on start.

The app works fine in local and in Expo’s simulator.

This is the build that crashes: https://expo.io/dashboard/ahmedsaeed/builds/eefc40b3-52b0-4060-82df-2b69cbe5ae7c

Any tip on how to debug this crashing apk?

Thank you

can you check logs with adb logcat or Android Studio?

This post was flagged by the community and is temporarily hidden.

I think this issue vary depends on your code but you might try adb logcat, I tried it and my issue was that I access Google Maps API key in a wrong way and that causes my app to crash as a standalone, here is the link for how to view logs for both Android and iOS Logging

For Android:

  1. Make sure that you have Android Sdk … I found it under Users/*Your user name here/Library/Android/sdk.
  2. Add this line to your .bash_profile or ./zshrc if you are on Mac OS Catalina
export PATH=/Users/*Your user name here/Library/Android/sdk/platform-tools:/Users/*Your user name here/Library/Android/sdk/tools:$PATH
  1. Open Android studio emulator or connect your device and make sure it’s connected properly then run adb logcat from your terminal then run APK that crushes.

  2. Try to watch your log to track what makes your app crash.

Hope it helps.