Android: There was an error with this build

#1

Hi guys!

I am trying to build my app with exp build:android
When i check status says: Android: There was an error with this build

Build ID: 10f3e6b8-ff07-4c58-818d-57bde5df4ab5

how can i check what is wrong with my project?

Thank you

#2

Could you send us your app.json?

#3

yes … this is it

{
“expo”: {
“name” : “VMachado”,
“icon” : “./src/images/vmachado.png”,
“description” : “App para controle do histórico de revisões do seu veículo”,
“slug”: “vmachado”,
“privacy” : “unlisted”,
“orientation” : “portrait”,
“sdkVersion”: “19.0.0”,
“version”: “1.0.2”,
“notification”: {
“icon” : “./src/images/notification.png”,
“color” : “#303f9f”,
“androidMode” : “collapse”,
“androidCollapsedTitle” : “#{unread_notifications} novidades”
},
“ios”: {
“bundleIdentifier”: “br.net.dex.vmachado”
},
“android”: {
“package”: “br.net.dex.vmachado”,
“versionCode” : 2,
“config” : {
“fabric” :{
“apiKey” : “xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”
},
“googleMaps” : {
“apiKey” : “xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”
}
}
}
}

#4

You need to specify both apiKey and buildSecret: https://docs.expo.io/versions/latest/guides/configuration.html#buildsecret

#5

i removed config and i got my apk! thank you!