App crashing on iOS only

Hello everyone,

I am sorry I am new to programming, I am trying to publish an app on AppStore but it seems to crash at launch and I don’t know how to test it on Windows, the Androïd and Web version are just fine but this is what I get when I try to submit it to AppStore (they sent back logs) : logs here

Expo CLI 4.3.4 environment info:
    System:
      OS: Windows 10 10.0.19041
    Binaries:
      Node: 14.15.4 - C:\Program Files\nodejs\node.EXE
      Yarn: 1.22.4 - C:\Users\charl\AppData\Roaming\npm\yarn.CMD
      npm: 6.14.10 - C:\Program Files\nodejs\npm.CMD
    IDEs:
      Android Studio: Version  3.5.0.0 AI-191.8026.42.35.6010548
    npmPackages:
      expo: ^40.0.0 => 40.0.1
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: https://github.com/expo/react-native/archive/sdk-39.0.3.tar.gz => 0.63.2
      react-native-web: ~0.13.12 => 0.13.18
      react-navigation: ^4.4.2 => 4.4.2
    Expo Workflow: managed

Thank you very much for reading me

Hey @charles.hdk, welcome to the Expo community! No need to apologize here. We all were new to programming at one point and time!

As for your logs you shared, we can’t view those as it’s tied to your apple account and trying to access it is forbidden.

More importantly, I would strongly suggest thoroughly reading our Debugging docs to get a better handle on how to approach the problem-solving process of squashing bugs/errors.

Cheers,
Adam

1 Like

Hi @adamjnav!

Thank you very much for the response!

Oh ok! I will read this doc to see what I can do.

Cheers,
Charles