App not picking up google maps api key anymore on Android

#1

I’m not sure what could’ve gone wrong as this used to work just yesterday, on the same emulator. I’ve tried other emulators too, same issue.

I defined my API key like:

    "android": {
      "config": {
        "googleMaps": {
          "apiKey": "the key"
        }
      }
    }

and when running the app I get an authentication error from the API, and this suggests to me the API key never ended up in the app in the first place:

11-03 02:49:16.173  7718  7884 E Google Maps Android API: Authorization failure.  Please see https://developers.google.com/maps/documentation/android-api/start for how to correctly set up the map.
11-03 02:49:16.174  7718  7884 E Google Maps Android API: In the Google Developer Console (https://console.developers.google.com)
11-03 02:49:16.174  7718  7884 E Google Maps Android API: Ensure that the "Google Maps Android API v2" is enabled.
11-03 02:49:16.174  7718  7884 E Google Maps Android API: Ensure that the following Android Key exists:
11-03 02:49:16.174  7718  7884 E Google Maps Android API: 	API Key: 
11-03 02:49:16.174  7718  7884 E Google Maps Android API: 	Android Application (<cert_fingerprint>;<package_name>):

Anyone else encountered this? I’d rather not eject the app solely to edit a manifest file, and I’m stumped.

I tried to clear the react native cached stuff and I ran expo r -c but to no avail.

1 Like
#2

the same issue

#3

For the record, upgrading Expo from 30 to 31 didn’t solve the issue.

I solved it by going the plain react-native route, I can’t really develop a map-based app if maps randomly stop working w/ no possibility of manual fixing w/o eject.

#4

I’m trying to figure out if expo app uses its own google api key during development. Because it works on standalone built.

#5

We’re working on it. Should be fixed today.

#6

I am still not able to load the MapView in live testing. Only works on standalone build

#7

Did you update Expo Client app?

closed #8

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.