Apple pay in web view

  1. SDK Version: 38
  2. Platforms(Android/iOS/web/all):
    IOS
    Hello, everyone,
    I was using expo 36 version and I implemented apple pay in a web view using react-native-webview package.

When I upgraded to expo 38, the webView package updated to 9.4.0 which breaks apple pay, I have tried to downgrade react-native-web-view to v7.6.0 but it did not work I am also getting the following warning message " react-native-web view - expected version range: 9.4.0 - actual version installed: 7.6.0 "

Hey @ram50,

We had to update our webview to dependencies to make sure that UIWebView references were no longer present in Expo apps as Apple would reject apps that still used it. https://dev.to/expo/expo-sdk-37-is-now-available-69g

You could try going down to 8.1.1 (https://github.com/expo/expo/blob/master/CHANGELOG.md#3700) and working from there but not using the versions expected based on your expo sdk means you’ll be operating at your own risk.

Cheers,
Adam

Cheers,
Adam

Thanks, Adam,
As I have read (https://github.com/expo/expo/blob/master/CHANGELOG.md#3700), I can submit a new build to the App Store using expo 36 or higher but in expo 36 react-native-web-view is at 7.4.3 version
Do you have any idea if I downgrade to expo 36 will my app be approved?

Thanks again

I’m fairly confident it won’t as Apple says they won’t allow apps that use the deprecated UIWebView.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.