Are instructions for upgrading ExpoKit iOS to version 22 ready?

#1

Hi, I saw that on https://github.com/expo/expo/releases version 2.10.2 for iOS was released a few days ago. Is there something wrong with that version or have you just not gotten around to updating the Medium post? I would really appreciate it if the instructions would be published. Thanks for the great work you are doing at Expo!

0 Likes

#2

Hey @redpandatronics,

Are you asking for SDK32 upgrade instructions? If so, you can find them here: https://blog.expo.io/expo-sdk-v32-0-0-is-now-available-6b78f92a6c52 Make sure you follow our blog so you can see when we post release announcements and upgrade instructions.

Cheers,

Adam

0 Likes

#3

Thanks Adam, but I mean at the bottom where it says: Updating ExpoKit to SDK 32 it says for the iOS instructions we should check back soon. I was just wondering if there are any updates on that? The app I want to upgrade is ejected, so I have to update ExpoKit too. Can’t wait to start using the background tasks :slight_smile:

0 Likes

#4

@adamjnav do you understand what I mean? Are the instructions ready yet for updating ExpoKit to version 22 for iOS? Do you know why it says in the blog post that we shouldn’t update iOS ExpoKit to version 22 yet? Is it safe to upgrade to version 22 of ExpoKit iOS using the instructions found here: https://docs.expo.io/versions/latest/expokit/expokit#ios-1 ? Can’t wait to update to v22 and start using the new features. Thanks

0 Likes

#5

@esamelson Hi Eric, I think you wrote the Medium post. Do you know when the instructions for updating ExpoKit to version 22 for iOS will be available? I’m really looking forward to that update :slight_smile: Thanks

0 Likes

#6

Hi @redpandatronics - these instructions are ready now and posted in the docs: https://docs.expo.io/versions/v32.0.0/expokit/expokit/#ios-1 . Let us know if you have any trouble! :slightly_smiling_face:

0 Likes

#7

Thanks @esamelson!

0 Likes

#8

@esamelson New instructions worked for me almost. First, pod update produced this error message:

[!] Unable to find a specification for `EXTaskManagerInterface` depended upon by `EXLocation`

Adding these 2 lines to my Podfile:

pod 'EXTaskManagerInterface',
      :path => "../node_modules/expo-task-manager-interface/ios"

Seems to have fixed it :slight_smile:

1 Like

#9

Got another error during build, but adding

pod 'EXAppLoaderProvider',
      :path => "../node_modules/expo-app-loader-provider/ios"

to the Podfile and running pod install seems to fix that too :slight_smile:
Thanks for the update instructions!

2 Likes

#10

Glad you got things working @redpandatronics and thanks for sharing those upgrade issues and resolutions. Also, my apologies for not understanding your question at first glance.

0 Likes

closed #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

0 Likes