Assets missing only in iOS release build after ejecting

Hi,

I recently ejected from expo 38 and since then my static images are not showing when I run the app in release mode on iOS, no errors are reported either. Works fine on Android for both release and debug.

When I print the uri of an image it points to APP_ID/Library/Application Support/.expo-internal/assets/assets/my-image.png.
Inside my simulator there’s no assets folder inside .expo-internal however all my assets are there at the root of .expo-internal with their original names replaced by hexadecimal strings (ex: 24d3a85009cdd5cd76c2e066c450de2d.png).

I’ve tried to build an offline bundle and adding it to Copy Bundle Resources in Build Phases as explained here but to no avail.

Here is the expo diagnostics:
Expo CLI 3.25.1 environment info:
System:
OS: macOS 10.15.5
Shell: 5.7.1 - /bin/zsh
Binaries:
Node: 12.18.3 - /usr/local/opt/node@12/bin/node
npm: 6.14.6 - /usr/local/opt/node@12/bin/npm
IDEs:
Android Studio: 4.0 AI-193.6911.18.40.6626763
Xcode: 11.5/11E608c - /usr/bin/xcodebuild
npmPackages:
expo: ^38.0.8 => 38.0.9
react: ~16.11.0 => 16.11.0
react-dom: 16.11.0 => 16.11.0
react-native: ~0.62.2 => 0.62.2
react-native-web: ~0.11.7 => 0.11.7
npmGlobalPackages:
expo-cli: 3.25.1

Is there a way to make the assets keep their initial names and go to where the uris are pointing to ?

Thank you.

Ok I found out the problem.
When ejecting, expo is supposed to generate a metro.config.js file that looks like that:

module.exports = {
    transformer: {
        assetPlugins: ['expo-asset/tools/hashAssetFiles']
    }
};

I presume it makes sure the assets are bundled correctly.
However I already had a metro.config.js file prior to ejecting that I needed for a svg library so expo didn’t generate a new one.

In future version of expo it would be practical if the eject process could add the necessary configuration inside the metro.config.js if the file already exists.