AuthSession.getRedirectUrl does not work after building the application (standalone app)

  1. SDK Version: 35
  2. Platforms(Android/iOS/web/all): Android

expo diagnostics

Expo CLI 3.4.1 environment info:
    System:
      OS: Windows 10
    Binaries:
      Yarn: 1.17.3 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
      npm: 6.9.0 - C:\Program Files\nodejs\npm.CMD

app.json

 "expo": {
    "name": "App Name",
    "slug": "app-name",
    "privacy": "public",
    "sdkVersion": "35.0.0",
    "scheme": "appname",
    "platforms": [
      "ios",
      "android",
      "web"
    ],
    "version": "1.0.0",
    "orientation": "default",
    "icon": "./assets/images/icon.png",
    "splash": {
      "image": "./assets/images/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "ru.name.app.my",
      "config": {
        "googleSignIn": {
          "reservedClientId": "key"
        }
      }
    },
    "android": {
      "package": "ru.name.app.android",
      "googleServicesFile": "./google-services.json"
    }
  }
}

AuthSession.getRedirectUrl does not work after building the application (standalone app).

I use the redirect url for authorization, through the AuthSession. The transition to the browser for authorization occurs, but there is no return to the application.

I get a similar error - Open image

I get a redirect url like this:
let redirectUrl = AuthSession.getRedirectUrl();

I tried to set “scheme”: “https”, but it did not help.

In an unassembled application, the redirect works, it does not work only with the assembled (standalone) application.