Black screen for camera

#1

I’m trying to run this code: https://snack.expo.io/By2WCSfnW.
I tried it on 3 different devices. The camera works fine on one of these device, but it shows black screen on the other two.
The expo app installed has Camera permission on all these devices.

#2

Could you share what types of devices you tried?

#3

We also tried this app: https://expo.io/@community/camerja.

We tried with these devices:

  • Vivo V5: both apps worked, as expected
  • Moto G5 S+: community version worked, but the snack version didn’t (black screen, with only ‘Flippppp’ written at the bottom)
  • One Plus 3T: both versions didn’t work (black screens)
#4

Exactly, I am using oneplus 3. Camerja App does not work, shows black screen, I tried to integrate camera to my project again black screen. I was able to use react-native-camera successfully on this device. this one opens properly but not sure if it is using camera component https://expo.io/@macwilly1/camera-test

1 Like
#5

Same problem here, camera shows a black screen on OnePlus 2, although it is working flawlessly on other devices

1 Like
#6

same problem here camera work on iphone 5s, and huawei p10 , but doesnt work on oneplus 3

#7

also, barCodeScanner works perfectly one oneplus 3 but not Camera

#8

This is an Intermittent behavior. Same problem with Samsung S7 Plus and S6 Plus.

Tip: If you show the list of all apps that you have recently accessed and come back to Expo, the camera will works. Of course that our costumers never will discover something like that.

Please @ide solve it asap for us!!!

#9

@lrebitte On devices where the camera works, if you are getting a black screen it may be because you are mounting more than one camera component at a time, which is not supported on Android and iOS.

Just to set expectations, we can’t fix everyone’s issues as fast as everyone wants them to be fixed. You can detach and use ExpoKit as an escape hatch if you need to write native code for any reason.

1 Like
#10

Thanks, I’ll try it.

#11

Hello, unfortunately there is an issue with OnePlus devices and Camera just doesn’t show up. I still haven’t found the reason and will be really helpful if someone would help as I don’t really have an access to such a device :frowning: Maybe something similar happens with Samsung S7 and S6.

#12

Having the same issue with the BarCodeScanner now after updating to v23. Also using a OnePlus 3T. It’s also making the Expo app itself difficult to use since I can’t scan QR codes now.

#13

I opened an issue:

#14

Hi Guys, I would like to hire the best developer in Expo.io to solve my problem with Black Screen. It’s occurring 90% of times. “Camera is not running”.