Build /bin/sh Error after Ejecting 30.0.0

#1

Today I created a new expo app with expo init. I migrated a bunch of js files over from another app, prepped everything for ejecting from expo. Ejected just fine. Pod Install in ios folder. Attempt to run the app and receive the following error:

“Command /bin/sh failed with exit code 127”

I was doing some digging and it looks like my older expo projects didn’t have a “Bundle Expo Assets” script under “Build Phases”. This has a “Shell” value of “/bin/sh”. For this reason, I am assuming this is the script causing the error. Is this an error in 30.0.0 or did I do something wrong?

Any suggestions were would be great. Thanks!

Edit: It looks like it is the Prepare Expo script erroring.

#2

Solved: Expo-source build error in AS

#3

Glad you got it solved. That post you linked just brought back some memories haha.

1 Like
#4

If any expo team member sees this, it might be worth testing if you are able to correctly eject without exp installed. Currently the docs or ask you to install expo-cli. I was receiving this error until I npm installed exp. I could be wrong but based on my experience it might require people to have both or something is missing from expo-cli.

1 Like
Ejected App Not loading the requested app (30.0.0)
#5

@scasarotto
Thanks for this report, we didn’t know about that. We found the cause why you needed to install exp - we will try to fix it asap! :wink:

1 Like
#6

@tsapeta Happy to help! The only reason I ran into it was because I moved to a brand new computer recently so I hadn’t installed exp yet. Just doin my part :wink:

1 Like
#7

We’ve just fixed this problem - so expo eject should work without exp installed. Again, thanks for your report!

1 Like
#8

Happy to help. You guys do so much great work and open source it. Anytime I can find something and report it with good certainty, I will. Feel free to close this thread.

1 Like
closed #9