Build error, ios-shell-app Errored, "Error: write EPIPE"

#1

I’m having trouble building a standalone app for both IOS and Android.

Under “running gulp task”, I see this error:

IOS

[stderr] [22:17:04] 'ios-shell-app' errored after 811 ms
[stderr] [22:17:04] Error: write EPIPE
[stderr]     at _errnoException (util.js:992:11)
[stderr]     at WriteWrap.afterWrite (net.js:864:14)

ANDROID

[06:07:45] Using gulpfile /src/exponent/tools-public/gulpfile.js
[06:07:45] Starting 'android-shell-app'...
[stderr] [06:07:46] 'android-shell-app' errored after 214 ms
[stderr] [06:07:46] Error: write EPIPE
[stderr]     at _errnoException (util.js:1021:11)
[stderr]     at WriteWrap.afterWrite (net.js:860:14)

Please help.

I’m using the latest version of Expo and I’ve simply typed “exp build:android” or “exp build:ios” to try building.

When using the simulator, the app seems to build and run fine.

#2

You should give it a try again! We had some issues with our build system last night.

More information here: http://expo.statuspage.io/

#3

Ok trying again right now.

But could you please tell me how I can get more info from my error? The error message doesn’t explain anything to me.

#4

Just tried and failed with the same issue.

Could you please help? This is a huge bottleneck for me.

Tyvm in advance.

#5

Hi, I’m still waiting on this issue. I’ve spent quite a bit of time trying to fix this by myself by trial and error – but still no luck.

If someone could please help me resolve this or help me see a more detailed error message, I would really appreciate it.

#6

Hello @saeho,
we have access to more detailed logs and it turns out that the error you have, may be caused by having a lot of assets in your app. It seems that our builder doesn’t handle well having >1.5k assets in an app. We should definitely make the error message more descriptive, additionally i’ll check why it’s a problem for our builder in the first place. Sorry for the trouble. I’ll let you know when we fix the issue.

#7

Hi @dsokal .

I use a lot of assets in the app because I use Twemojis. I really must have Twemojis in my app.

What is the best work-around for this? Also when do you think this builder issue can be resolved?

#8

Hi @dsokal

I’ve managed to (painfully) avoid this problem by selectively adding only 500 of the Twemojis I really need. But this is a temporary solution for me.

May I please know when this asset issue will be resolved?

#9

The issue should be fixed now. Please let me know if you’re still experiencing the original problem.

closed #10

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.