Bundle your assets inside your standalone binary - not working


#1

Having issues getting this to work properly.

i have tried all combinations of paths in the app.json
right now i have a test folder within my assets folder with only three small jpgs inside.

i have tried:

"assetBundlePatterns": [
  "./assets/test/**"
]

as well as
"./assets/test/"
"assets/test/
"
“assets/test/**”

but when i run exp build:android and check the contents of the apk once downloaded… there are no images to be found.

i have even tried direct path’s to the jpegs themselves with no success.

currently on expo version 25.0.0


What Is Path to / Location of Files Bundled with assetBundlePatterns in SDK v25?
#2

Hello,

What OS and what version of the exp command line tool are you using?


#3

hey @janic,

currently on windows 8. and version 46.0.3 for the cli.

I hadn’t considered the cli… i’ll run an update on that now


#4

hey @janic,

seems to be working now. It’s a pity the documentation only states version 25 of expo and doesn’t mention cli versions… i lost an entire day to this.

Thanks for mentioning the cli version.


#5

Sorry about that, I will make sure to update the doc!


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.