Can I use FlatList yet?

#1

Hi I am trying to use FlatList which I believe requires react-native 43.3 - but after upgrading to react-native 43.3 i got an “unexpected token” error on a use of @observer (i’m using mobx).

Looking around I found this page:


which seems to indicate that expo does not yet support react-native 0.43 - so no FlatList. Do I have this right? And if so, when will 0.43.x support be going down the pike?
Thanks!
Chris
Cambridge, MA

1 Like
#2

Today, if all goes well!

1 Like
#3

In the next SDK release which should be very soon!

1 Like
#4

SDK 16 is released now!
https://blog.expo.io/expo-sdk-v16-0-0-is-now-available-2151d555a580

1 Like
#5

awesome. excited to try FlatList. Ha I feel like every page in my app is just going to be a FlatList. Appreciate the detailed upgrade instructions too