Cannot Find Android Keystore file - Request failed with status code 400


#1

I am trying to publish an updated version of an Android application, the original version of which was published by someone who no longer works with me.

I have run expo fetch:android:keystore and it’s successfully downloaded the .jks file and provided me with the Keystore password, Key alias and Key password.
Then when I run expo build:android -c I enter the path to the .jks file along with the information provided.
I then get an error message of Request failed with status code 400.

I can’t see any information in the docs about what a 400 error message is.


#2

Same problem here!

We have an app previously built on phonegap and now migrated to React Native/Expo. We are trying to build the android .apk using the keystore we had before and we get the following error:

I know that the problem is not with my .keystore, since through expo fetch:android:keystore I’ve got the keystore generated by EXPO and it gives me the same error!

Using expo build:android works fine, but I can’t deploy since the fingerprints doesn’t match with the app I have already published.

Any one any idea?


#3

Hey @gluedigistu

There was an issue with expo-cli 2.7.1 and it’s fixed on 2.7.2. So just needed to update my cli version!