Cannot Upgrade Expo sdk to 37.0.0 version

Please provide the following:

  1. SDK Version: 36.0.0
  2. Platforms(Android/iOS/web/all): all


I want to open my expo project but it raises this error. So I tried expo upgrade However, I got error like this.
Failed to install expo package with error: yarnpkg exited with non-zero code: 1
yarnpkg exited with non-zero code: 1
Error: yarnpkg exited with non-zero code: 1
at ChildProcess.completionListener (C:\Users\amorqiu\AppData\Local\Yarn\Data\g
lobal\node_modules@expo\spawn-async\src\spawnAsync.ts:65:13)
at Object.onceWrapper (events.js:421:26)
at ChildProcess.emit (events.js:314:20)
at ChildProcess.cp.emit (C:\Users\amorqiu\AppData\Local\Yarn\Data\global\node_
modules\cross-spawn\lib\enoent.js:34:29)
at maybeClose (internal/child_process.js:1047:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)

at Object.spawnAsync [as default] (C:\Users\amorqiu\AppData\Local\Yarn\Data\gl
obal\node_modules@expo\spawn-async\src\spawnAsync.ts:26:19)
at YarnPackageManager._runAsync (C:\Users\amorqiu\AppData\Local\Yarn\Data\glob
al\node_modules@expo\package-manager\src\NodePackageManagers.ts:288:31)
at YarnPackageManager.addAsync (C:\Users\amorqiu\AppData\Local\Yarn\Data\globa
l\node_modules@expo\package-manager\src\NodePackageManagers.ts:241:16)
at upgradeAsync (C:\Users\amorqiu\AppData\Local\Yarn\Data\global\node_modules
expo-cli\src\commands\upgrade.ts:465:5)
at C:\Users\amorqiu\AppData\Local\Yarn\Data\global\node_modules\expo-cli\src\c
ommands\upgrade.ts:701:7
at Command. (C:\Users\amorqiu\AppData\Local\Yarn\Data\global\node_m
odules\expo-cli\src\exp.ts:302:7)

I followed some instructions like uninstall expo-cli and update it. But it still doesn’t work for me. I saw another Expo sdk upgrade error topic where people also has similar problem but nobody solved it.

node version v14.10.1
expo-cli --version 3.27.4
npm --version 6.14.8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.