Can't build Android

i updated my project to sdkVersion 34 and every time i try to build android using the comamnd expo build:android expo trhow the error:

Publishing to channel ‘default’…
Building iOS bundle
connect ECONNREFUSED 127.0.0.1:19001
Error: connect ECONNREFUSED 127.0.0.1:19001
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1097:14)

i tried to delete node_modules, reinstal using yarn and npm, back to 32, clear cache using expo start -c

Hi

What does expo diagnostics give you? Post it here like this:

```
diagnostics here
```

Also, do you have the same SDK version in app.json and package.json?

Does expo start work for you after upgrading to SDK 34?

@tigpalmas2 you need to run expo start before running expo build:android :+1:

2 Likes

Thanks Charlie.

This is new. So now we have to run expo start and then expo publish in another terminal.

No, sorry, you should run expo start at some point before building your binaries. You don’t have to keep it running during the build

1 Like

Thanks for clarifying. I had the same ECONNREFUSED message when running expo publish. I had to run expo start in one terminal and then expo publish in another. No error message. My case could be isolated.

I haven’t tried expo build yet but will later.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.