Can't build ios


#1

I have two factor authentication enabled (can’t turn it off because Apple won’t allow it after September 2018)

Here’s a screenshot, it kept asking for 6 digit code (which is sent through my phone) and it stuck at “Now producing files for distCert”. I can’t enter a code or anything, all I can do is to cancel the process.

When I enter the code, it immediately return “Your session has been expired”


#2

Hey @syahrul,

A couple questions for ya! What OS are you on, what shell are you using and what version of the expo-CLI are you running?

Cheers,

Adam


#3

macOS High Sierra 10.13.6
bash
expo 2.6.5


#4

I have the same situation


#5

Hello @syahrul @harrison0723,
please install a new version of expo-cli - 2.6.9. Since this version you should be prompted for 2FA code only once.
Please let us know if it fixes the issue for you.


#6

@dsokal if you want us to install a new version, please fix before https://github.com/expo/expo-cli/issues/247, all pipeline was broken after I updated to latest 2.6.9 :frowning: - works fine in 2.4.3.


#7

Upgraded to 2.6.9 and expo-cli doesn’t work anymore, can’t run expo build:ios

[23:55:35] Error: React Native is not installed. Please run npm install in your project directory.

[23:55:35] There is an error with your project. See above logs for information.

[23:55:35] Set EXPO_DEBUG=true in your env to view the stack trace.

Roll back to 2.6.5


#8

So I managed to get around the issue with the previous version by simply keeping on typing my 2FA code and press enter, it won’t reflect on the command line but you’ll see it work when it starts installing other stuff. It’s glitchy for sure tho.


#9

@syahrul
Please upgrade to 2.6.10 (https://github.com/expo/expo-cli/issues/248#issuecomment-445878928)

@harrison0723
If you were getting the same error (React Native is not installed) please install expo-cli@2.6.10 as well. Otherwise, the issue with asking for 2FA code multiple times is fixed since 2.6.9.


#10

Thanks @dsokal