Can't create projects after upgrade

#1

After successfully working on a project I upgraded expo this morning. Both expo init and creat-react-native-app now crash with an error in zlib. Anyone any clues?

C:\projects>expo init Test2
? Choose a template: expo-template-blank
[15:44:08] Extracting project files…
[15:44:09] zlib: Cannot read property ‘length’ of null
[15:44:09] ZlibError: zlib: Cannot read property ‘length’ of null
at Unzip.Zlib.(anonymous function) (C:\Users…\AppData\Roaming\npm\node_modules\expo-cli\node_modules\minizlib\index.js:126:21)
at Unzip.write (C:\Users…\AppData\Roaming\npm\node_modules\expo-cli\node_modules\minizlib\index.js:247:21)
at Unzip.flush (C:\Users…\AppData\Roaming\npm\node_modules\expo-cli\node_modules\minizlib\index.js:206:10)
at Unzip.end (C:\Users…\AppData\Roaming\npm\node_modules\expo-cli\node_modules\minizlib\index.js:213:10)
at Unpack.end (C:\Users…\AppData\Roaming\npm\node_modules\expo-cli\node_modules\tar\lib\parse.js:415:21)
at PassThrough.onend (_stream_readable.js:598:10)
at Object.onceWrapper (events.js:254:19)
at PassThrough.emit (events.js:164:20)
at endReadableNT (_stream_readable.js:1054:12)
at _combinedTickCallback (internal/process/next_tick.js:138:11)
at process._tickCallback (internal/process/next_tick.js:180:9)

C:\projects>expo diagnostics

Expo CLI 2.6.14 environment info:
System:
OS: Windows 10
Binaries:
npm: 6.4.1 - C:\Users…\AppData\Roaming\npm\npm.CMD
IDEs:
Android Studio: Version 3.2.0.0 AI-181.5540.7.32.5056338

#2

Hey @victorh,

It looks like this is a known issue when running a node version less than 10.x. https://github.com/nodejs/node/issues/17041 If you are below that, do you think you could try updating node and see if that fixes it?

Cheers,

Adam

#3

After installing node.js from https://nodejs.org/en/ to v11 I was able to create the project again. Thanks.

1 Like
closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.