I’m on a bare react native cli project, using various expo libraries successfully via unimodules. However I can’t install expo-brightness. After installing the package I ran pod install
cd ios && npx pod-install and get the following error:
[!] CocoaPods could not find compatible versions for pod "EXBrightness": In Podfile: EXBrightness (from `../node_modules/expo-brightness/ios`) Specs satisfying the `EXBrightness (from `../node_modules/expo-brightness/ios`)` dependency were found, but they required a higher minimum deployment target.
Does anyone know a fix? I’m just trying to get this to work on IOS don’t really care about Android for now…
"react-native": "0.63.4", "react-native-unimodules": "^0.12.0", "expo-brightness": "^9.0.0",
require_relative '../node_modules/react-native/scripts/react_native_pods' require_relative '../node_modules/@react-native-community/cli-platform-ios/native_modules' require_relative '../node_modules/react-native-unimodules/cocoapods.rb' platform :ios, '10.0' target 'foo' do use_unimodules! config = use_native_modules! use_react_native!(:path => config["reactNativePath"]) pod 'CodePush', :path => '../node_modules/react-native-code-push' target 'fooTests' do inherit! :complete # Pods for testing end # Enables Flipper. # # Note that if you have use_frameworks! enabled, Flipper will not work and # you should disable these next few lines. use_flipper! post_install do |installer| flipper_post_install(installer) end end