Can't install ios simulator build in simulator

My app is fully in Expo, by which I mean I haven’t ejected it.

I’ve built it with expo build:ios -t simulator.

When trying to install it on the simulator I get this error:

$ xcrun simctl install booted /Users/TuzMacbookPro2017/Development/QMG-local/APPS/Builds/iOS\ Simulator/electro.app 
An error was encountered processing the command (domain=IXUserPresentableErrorDomain, code=1):
This app could not be installed at this time.
Failed to chmod /Users/TuzMacbookPro2017/Library/Developer/CoreSimulator/Devices/52FCF3B9-1495-4B7D-BBB8-DDDC4FA12A7C/data/Bundle/Application/32585836-50D7-4CAA-A161-03C231F14585/electro.app/ComJoinelectroElectroMobile : No such file or directory
Failed to chmod /Users/TuzMacbookPro2017/Library/Developer/CoreSimulator/Devices/52FCF3B9-1495-4B7D-BBB8-DDDC4FA12A7C/data/Bundle/Application/32585836-50D7-4CAA-A161-03C231F14585/electro.app/ComJoinelectroElectroMobile : No such file or directory
Underlying error (domain=MIInstallerErrorDomain, code=4):
	Failed to chmod /Users/TuzMacbookPro2017/Library/Developer/CoreSimulator/Devices/52FCF3B9-1495-4B7D-BBB8-DDDC4FA12A7C/data/Bundle/Application/32585836-50D7-4CAA-A161-03C231F14585/electro.app/ComJoinelectroElectroMobile : No such file or directory

Any thoughts on how to fix this?


A bit of background: I submitted an earlier build to TestFlight and got rejected; they said it crashed on launch. So I’m trying this new build, which works in Expo (like the old one did) but now I’m working on installing the build on device or on sim to see if it loads.

2 Likes

Hey @tuzmusic- what version of Xcode are you running? Could you run expo diagnostics and paste the output here?

Xcode 10.2.1

Here’s the diagnostic output:

$ expo diagnostics
  Expo CLI 2.21.1 environment info:
    System:
      OS: macOS 10.14.5
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 11.12.0 - /usr/local/bin/node
      Yarn: 1.15.2 - /usr/local/bin/yarn
      npm: 6.10.0 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    IDEs:
      Android Studio: 3.4 AI-183.5429.30.34.5452501
      Xcode: 10.2.1/10E1001 - /usr/bin/xcodebuild
    npmPackages:
      expo: ^33.0.0 => 33.0.7 
      react: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8 
      react-navigation: ^3.9.1 => 3.9.1 
    npmGlobalPackages:
      expo-cli: 2.21.2
1 Like

@tuzmusic solution here: https://github.com/expo/expo-cli/issues/841#issuecomment-511084909

1 Like

I have the same problem.

  Expo CLI 2.21.2 environment info:
    System:
      OS: macOS 10.14.5
      Shell: 5.3 - /bin/zsh
    Binaries:
      Node: 12.4.0 - /usr/local/bin/node
      Yarn: 1.16.0 - /usr/local/bin/yarn
      npm: 6.9.0 - ~/.npm-packages/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    IDEs:
      Android Studio: 3.4 AI-183.6156.11.34.5522156
      Xcode: 10.2.1/10E1001 - /usr/bin/xcodebuild
    npmPackages:
      expo: ^33.0.7 => 33.0.7 
      react: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8 
      react-navigation: ^3.11.0 => 3.11.0 
    npmGlobalPackages:
      expo-cli: 2.21.2

Thanks! This fixed the issue for me.

Expo CLI 2.21.2 environment info:
    System:
      OS: macOS 10.14.5
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 8.9.1 - /usr/local/bin/node
      npm: 6.10.1 - /usr/local/bin/npm
    IDEs:
      Xcode: 10.2.1/10E1001 - /usr/bin/xcodebuild
    npmPackages:
      expo: ^33.0.0 => 33.0.7 
      react: ^16.6.3 => 16.8.6 
      react-native: ^0.59.8 => 0.59.10 
      react-navigation: ^2.14.2 => 2.18.3 
    npmGlobalPackages:
      expo-cli: 2.21.2

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.