Can't upload on AppStore (terminal not interactive)

#1

Hi
I have a problem when I want to upload my build with expo-cli command.

I’m doing this:
expo upload:ios --latest --apple-id myAppleId --apple-id-password myPassword --language French

But then, I got this error:
Multiple App Store Connect Teams found; unable to choose, terminal not interactive!

It seems that there is no problem with my terminal because I can do interactive command with expo-cli like login or build:ios (enter credentials). Or is there any options to activate interactive mode ? Thanks for your help !

0 Likes

#2

Hey @martinezguillaume,

What OS are you on and what shell are you using?

Cheers,

Adam

0 Likes

#3

I’m on MacOS Mojave, and I’m using the Terminal from macOS (with ohmyzsh)

Envoyé de mon iPhone

0 Likes

#4

any news ? I tried it with another mac with iTerm 2 but same problem

0 Likes

#5

Hello,
what version of expo-cli do you have?

0 Likes

#6
expo --version

2.7.1
0 Likes

#7

I have the same problem with 2.7.1. I have two memberships under the same Apple id in app store connect. One personal and one for the company I work with. It seems like the CLI requires to choose which account to use.

I tried to see if there’s a way to set one as the default at Apple but couldn’t find it.

Also I haven’t published any apps with my apple id yet. Maybe that is also a factor…

0 Likes

#8

Hi
For now you can use as a workaround setting FASTLANE_TEAM_ID and FASTLANE_ITC_TEAM_ID env variables. I’ll try to look into interactive mode problem later this week.

0 Likes

#9

Thanks, that works!

For anyone like me wondering where to find those ids: Just fill in something bogus and the cli will print the ids that match your various accounts.

0 Likes

#10

Thanks it works !

0 Likes

closed #11

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

0 Likes