Custom fonts not loading after upgrading to SDK 36

  1. SDK Version: 36
  2. Platforms(Android/iOS/web/all):

i’m getting this error:

console.error: "fontFamily “montserrat-bold” is not a system font and has not been loaded through Font.loadAsync.

  • If you intended to use a system font, make sure you typed the name correctly and that it is supported by your device operating system.

  • If this is a custom font, be sure to load it with Font.loadAsync."

_construct
construct.js:30:26
Wrapper
wrapNativeSuper.js:26:23
SyntheticError
AppEntry.bundle?platform=ios&dev=true&minify=false&hot=false:28811:111
reactConsoleErrorHandler
ExceptionsManager.js:135:52
__expoConsoleLog
RemoteConsole.js:80:37
error
muteWarnings.fx.js:27:24
processFontFamily
Font.js:23:16
renderRoot
[native code]:0
runRootCallback
[native code]:0
unstable_runWithPriority
scheduler.development.js:643:23
Component.prototype.forceUpdate
react.development.js:343:34
initFunc
HomeScreen.js:175:16
setTimeout$argument_0
HomeScreen.js:178:14
_callTimer
JSTimers.js:146:14
callTimers
JSTimers.js:399:17
callFunctionReturnFlushedQueue
[native code]:0

I had the same problem. Execute this line of code and it will works. This is a cache problem.

watchman watch-del-all && rm -rf $TMPDIR/react-* && rm -rf node_modules/ && rm -f package-lock.json && rm -f yarn.lock && npm cache verify && npm install && expo r -c
3 Likes

Thanks a lot …that worked!

2 Likes

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.