Detached app - expolib1_v1.http3 problem

#1

Hi! I just detached an app because i need react-native-fetch-blob. Before installing the dependency everything worked fine. After installing the packet, and linking it, the gradle build fails. It seems that the react native code “OkHttpClientProvider.getOkHttpClient()” imported from “import com.facebook.react.modules.network.OkHttpClientProvider;” returns expolib1_v1.okhttp3.OkHttpClient instead of okhttp3.OkHttpClient. Is there a way to resolve this? Or do I need to remove all references to expo and fallback on basic react-native?

#2

Hi! Is OkHttpClientProvider the only way to get an OkHttp client for fetch-blob? I seem to recall a way to work around this by not attempting to share the client instance with RN.

#3

Hmmm. Is expo making breaking changes with the OkHttpClient? Or I could theoretically make a clone of react-native-fetch-blob which uses expos version?

#4

I don’t believe we’re making any significant changes other than namespacing the package, so I think you could probably make it work. Blob support for fetch should be supported in upstream React Native soon (fingers crossed!), but a workaround like that in the meantime might be the right call.

#5

Thanks for the help! I changed the namespace in the react-native-fetch-blob package and now the app runs, but I haven’t really tested the package.