Device: (1002:881) null is not an object (evaluating 'd.NativeModulesProxy')


#1

my already stable snack started to show this error on the Expo app (still works fine on Expo web)

can anyone help please?!


#2

Hey @cabteix,

Are you able to share the Snack? Also, can you make sure you are running the latest version of the Expo client for whichever platform this is occurring on?

Cheers,

Adam


#3

hey @adamjnav! it’s really odd… if I remove the following imports one by one e put them back one by one, the problem goes away UNTIL I need to open the snack again… I’m the Expo Project 2.10.3 published in the Play Store on Jan 9th 2019

import TokenScreen from ‘./components/Token’;
import CheckoutScreen from ‘./components/Checkout’;
import SearchScreen from ‘./components/Search’;
import UsersListScreen from ‘./components/UsersList’;
import ShowUserScreen from ‘./components/ShowUser’;
import UsersScreen from ‘./components/Users’;
import MerchantsScreen from ‘./components/Merchants’;
import ConfigScreen from ‘./components/Config’;

const App = createStackNavigator({
Token: {screen: TokenScreen},
Checkout: {screen: CheckoutScreen},
Search: {screen: SearchScreen},
UsersList: {screen: UsersListScreen},
ShowUser: {screen: ShowUserScreen},
Users: {screen: UsersScreen},
Merchants: {screen: MerchantsScreen},
Config: {screen: ConfigScreen}
}
);


#4

@cabteix glad to hear you’re unblocked at least, but it should work on first load as well. Please send us a link to the snack so we can diagnose what’s happening.


#5

#6

any luck?!


#7

hey @thetc … that workaround is no longer an option :frowning: any luck with the troubleshooting?!


#8

Hey @cabteix,

We have some internal meetings today. Please don’t spam the forums. We’ll respond when we have actionable information for you.

All the best,

Adam


#9

Hey @cabteix
I just tested and its running fine for me in the latest client on both platforms.
If its still not for you, update to the latest client (2.10.4 is out). Maybe uninstall and reinstall as a last resort in case you have something cached locally, although I’m not thinking of any local cacheing we do that could bite you like this


#10

found the problem… latest Expo app version (released Jan 16th) updated to react native elements 1.0.0-alpha.22 whilst their official supported version is 0.19.1


#11

would it be possible for Expo to either automatically update libraries, warn about changes or allow for a manual change verification?


#12

As shown here, add import {Icon} from "react-native-vector-icons/MaterialIcons"; solves the problem. Solution is found Snack runs on the simulator but not in a real phone


closed #13

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.