Downgrade Expo Client app in iOS simulator

#1

Hi just upgraded the Expo Client app in iOS simulator to the latest version, only to find out that the latest Expo Client app doesn’t support the sdk (21) our project is built on currently. (The latest Expo client only support projects with sdk 22+)

Now it’s not a particularly good timing for us to upgrade sdk version; so I’m trying to figure out a way to install older version of Expo Client app in the iOS simulator.

I tried the manual install method mentioned here https://gist.github.com/jesseruder/a627c0dc0427f074d1aecba997c349ef but the app file downloaded from http://expo.io/--/api/v2/versions/download-ios-simulator-build is latest Expo Client.

Is there a way to download older version of Expo Client app? Thanks.

#2

Managed to find the version.json file here https://github.com/expo/xdl/blob/master/caches/versions.json that has the url to the older version of the Expo Client.

So for anyone who got stuck like me, you can do the following to downgrade your Expo Client app in your iOS simulator:

  • Delete the current Expo Client in your simulator (Simulator Menu > Hardware > Home, then mouse long left click on the Expo Client app, click the cross to delete)
  • Download the older app here: https://dpq5q02fu5f55.cloudfront.net/Exponent-2.5.9.tar.gz (assuming it’s not deleted)
  • Untar the Exponent-2.5.9.tar.gz file
  • Run xcrun simctl install booted [PATH TO UNTARRED Exponent-2.5.9.tar.gz FOLDER] to install the older app to your simulator

To Expo team; first hugely appreciate all the hard work you guys put in; but maybe implement a warning when installing Expo client app in simulator that’s not compatible with users current project sdk.

1 Like
closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.