eas build > submit error. "You've already submitted this version of the app." irregardless of the build number

I just subscribed to EAS so that I could easily build my bare-workflow expo app. First, I used eas build to build my app, followed by eas submit. I was successfully able to submit my app and get a version on test flight.

The problem came when I tried to submit another build to the app store.

You've already submitted this version of the app. Versions are identified by Build Numbers (expo.ios.buildNumber in app.json). If you're submitting an Expo project built with EAS Build, increment the build number in app.json and build the project again.

I had bumped my app.json ios.buildNumber but it wasn’t recognized on subsequent builds. My first build was 1.0.0, and here’s what I tried:

"ios": {
  "buildNumber": "1.0.1",
  "supportsTablet": true,
  "bundleIdentifier": "com.pakaplace.reddit-alerts"
},

"ios": { "buildNumber": "2", "supportsTablet": true, "bundleIdentifier": "com.pakaplace.reddit-alerts" },

Same error each time I rebuilt via eas build and submitted. How can I properly resubmit new versions so that I can test on test flight before submitting to the app store.

when you have a bare app you need to bump the version in their appropriate locations in the native projects, not in app.json. we’re working on adding automatic version bumping of native projects so people don’t need to think about this at all, but it’s not ready quite yet. until then, just open xcode and update your version number then build.

Thank you notbrent.

Makes sense, I’ll try that out. The eas error message with its instructions to change the build number at expo.ios.buildNumber was what led me down the wrong path. I’m new to Xcode, iOS.

thanks! i’ll double check that

Sorry to bother you but my app (bare workflow), which works on my emulator and on a physical device with react-native run-ios, is crashing in test flight when built with eas build. Are there other similar XCode gotchas I should do before running eas build? I read that the scheme had to be changed to “release” not “debug”, so I’ve just tried that.

My app loads in test flight but upon sign-in it crashes. It’s not doing this on the simulator, and I’m having trouble locating helpful logs to get a root cause. Below is my expo diagnostics

  Expo CLI 4.1.3 environment info:
    System:
      OS: macOS 11.0.1
      Shell: 5.8 - /bin/zsh
    Binaries:
      Node: 14.7.0 - /usr/local/bin/node
      Yarn: 1.22.4 - /usr/local/bin/yarn
      npm: 6.14.7 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    Managers:
      CocoaPods: 1.10.1 - /usr/local/bin/pod
    SDKs:
      iOS SDK:
        Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
    IDEs:
      Android Studio: 4.1 AI-201.8743.12.41.7042882
      Xcode: 12.4/12D4e - /usr/bin/xcodebuild
    npmPackages:
      @expo/webpack-config: ^0.12.52 => 0.12.58 
      expo: ~40.0.0 => 40.0.1 
      react: 16.13.1 => 16.13.1 
      react-dom: 16.13.1 => 16.13.1 
      react-native: ~0.63.4 => 0.63.4 
      react-native-web: ~0.13.12 => 0.13.18 
    npmGlobalPackages:
      expo-cli: 4.1.3
    Expo Workflow: bare

I have this issue, and I don’t have a bare app, what can I do?

you should look into your crashes in the xcode crash organizer or a tool like sentry. eas build doesn’t have anything to do with crashes of your app while it’s running, it just builds it

Thanks @notbrent . I understand these are probably routine, annoying questions for someone experienced in react native.

If my app is building fine in Test Code but crashing in EAS/Testlane, would Sentry or XCode organizer still be a good tool to diagnose the crash?

If my app is building fine in Test Code but crashing in EAS/Testlane, would Sentry or XCode organizer still be a good tool to diagnose the crash?

try doing a release build in xcode locally (change scheme build configuration to release from debug). if you can’t reproduce the crash there, then yes those would be good places to look.