eas build ValidationError - Android and iOS

I’m getting the following error when running
$ eas build --platform ios

✔ Uploaded to EAS 3s
    ValidationError: "secrets.buildCredentials.provisioningProfileBase64" is required

and this when trying to build for Android:
$ eas build --platform android

✔ Uploaded to EAS 3s
    ValidationError: "builderEnvironment" is not allowed

Things I’ve tried:

  • rm -rf .expo
  • rm ~/.app-store
  • new bundle id to force new cert generation (iOS)
  • tried node 12 and node 14
$ expo diagnostics                                                                                  

  Expo CLI 4.1.6 environment info:
    System:
      OS: Linux 5.8 Linux Mint 20 (Ulyana)
      Shell: 5.8 - /bin/zsh
    Binaries:
      Node: 14.15.1 - ~/.nvm/versions/node/v14.15.1/bin/node
      Yarn: 1.22.4 - ~/.yarn/bin/yarn
      npm: 6.14.8 - ~/.nvm/versions/node/v14.15.1/bin/npm
    SDKs:
      Android SDK:
        API Levels: 28, 29, 30
        Build Tools: 28.0.3, 29.0.2, 30.0.1, 30.0.2
        System Images: android-30 | Google APIs Intel x86 Atom
    IDEs:
      Android Studio: 4.1 AI-201.8743.12.41.6953283
    npmPackages:
      expo: ~40.0.0 => 40.0.1
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: ~0.63.4 => 0.63.4
      react-native-web: ~0.13.12 => 0.13.18
    Expo Workflow: bare

I have an EAS subscription… this used to work, this error doesn’t make sense.


Edit 1 - Doesn’t happen on MacOS. Happens on Linux.

What version of eas-cli are you using? Also can you check what version of @expo/eas-json is installed on your system?

eas-cli/0.4.2 linux-x64 node-v12.18.3

Also can you check what version of @expo/eas-json is installed on your system?

Hmm I don’t see that installed anywhere. Grepped through yarn list and yarn global list.