Error after upgrading to Expo 20.0.0

#1

I am getting this error:

[exp] error TypeError: undefined is not an object (evaluating 'this._component.getScrollableNode')

Any idea where does this issue come from? I am getting it at the app loading.

#2

This is an error that happens in the Animated library. I’ve heard of it happening with function components. You might want to use a normal React component class instead (or PureComponent which is a sweet spot of sorts).

#3

I found the bug, it was caused because of “margin: 32”

1 Like