Error building an Expo project without ejecting

#1

Hi,

I’ve created a brand new project using Expo platform (without ejecting) and it’s running without errors on Android emulator, Android real device (using Expo app) and on an iOS device too. Everything without errors.

But when I try do build using “expo build:android”, I got the following error:

:expoview:compileReleaseAidl FAILED
:app:preProdMinSdkProdKernelReleaseBuild FAILED
[stderr] FAILURE: Build completed with 2 failures.
[stderr] 1: Task failed with an exception.
[stderr] -----------
[stderr] * What went wrong:
[stderr] Could not resolve all files for configuration ':expoview:releaseCompileClasspath'.
[stderr] > Could not find com.google.android.exoplayer:exoplayer-core:2.6.1.
[stderr]   Searched in the following locations:
[stderr]       https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.pom
[stderr]       https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.jar
[stderr]       https://jcenter.bintray.com/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.pom
[stderr]       https://jcenter.bintray.com/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.jar
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/expoview/libs/exoplayer-core-2.6.1.jar
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/expoview/libs/exoplayer-core.jar
[stderr]       https://jitpack.io/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.pom
[stderr]       https://jitpack.io/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.jar
[stderr]       https://maven.fabric.io/public/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.pom
[stderr]       https://maven.fabric.io/public/com/google/android/exoplayer/exoplayer-core/2.6.1/exoplayer-core-2.6.1.jar
[stderr]   Required by:
[stderr]       project :expoview > com.facebook.android:audience-network-sdk:4.99.0
[stderr] > Could not find com.google.android.exoplayer:exoplayer-dash:2.6.1.
[stderr]   Searched in the following locations:
[stderr]       file:/usr/local/android-sdk-linux/extras/m2repository/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.pom
[stderr]       file:/usr/local/android-sdk-linux/extras/m2repository/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.jar
[stderr]       file:/usr/local/android-sdk-linux/extras/google/m2repository/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.pom
[stderr]       file:/usr/local/android-sdk-linux/extras/google/m2repository/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.jar
[stderr]       file:/usr/local/android-sdk-linux/extras/android/m2repository/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.pom
[stderr]       file:/usr/local/android-sdk-linux/extras/android/m2repository/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.jar
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/maven/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.pom
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/maven/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.jar
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/versioned-abis/expoview-abi25_0_0/maven/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.pom
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/versioned-abis/expoview-abi25_0_0/maven/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.jar
[stderr]       file:/app/workingdir/android/sdk31/android-shell-app/versioned-abis/expoview-abi26_0_0/maven/com/google/android/exoplayer/exoplayer-dash/2.6.1/exoplayer-dash-2.6.1.pom

My project uses only theses dependencies:

"dependencies": {
    "@expo/samples": "2.1.1",
    "expo": "^31.0.2",
    "moment": "^2.22.2",
    "native-base": "^2.8.1",
    "react": "16.5.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-31.0.0.tar.gz",
    "react-native-animatable": "^1.3.0",
    "react-native-image-progress": "^1.1.1",
    "react-native-maps": "^0.22.1",
    "react-native-progress": "^3.5.0",
    "react-native-slider": "^0.11.0",
    "react-navigation": "3.0.7"
  },
  "devDependencies": {
    "babel-preset-expo": "^5.0.0",
    "jest-expo": "^31.0.0"
  },

What am I doing wrong? I have other projects (with a higher complexity) and it builds without errors.

Thanks!

closed #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.