ERROR ITMS-90725: SDK Version Issue... when submitting to iOS App Store

We’re currently experiencing an issue when attempting to upload the IPA file built by Expo into the Apple App Store. This issue was first experienced on April 27 and we last successfully built and submitted on April 8.

The error text is below, and it seems to be a version incompatibility issue there are a few topics about already in these forums.

ERROR ITMS-90725: “SDK Version Issue. This app was built with the iOS SDK. All iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later. Further, starting June 30, 2020, iOS app updates submitted to the App Store must be built with the iOS 13 SDK or later, included in Xcode 11 or later.”

I’ve looked through the existing topics on this, but I could not find a common thread or obvious solution. We have tried building our project using Expo SDK 36 and then quickly upgraded and tried SDK 37 and received the same error. We tried submitting the builds from Xcode 11.3.1 and 11.4. We also tried rebuilding and submitting the project using the exact same code and configuration as is currently in the app store and was built and submitted successfully on April 8 and received the same error.

We attempted initiating the build on multiple machines, macOS and Linux, using expo build:ios as has worked for us in the past.

Please advise, and let me know if there’s any more information I can provide that would be helpful. Thank you.

Hi! Sorry, this one’s an odd issue

It looks like this is the same as this post, which seemed to have been resolved by simply rebuilding and resubmitting, which I believe you’ve already tried? What version of expo-cli are you using?

This can be closed. We tried probably five times on the 27th and 28th but when we retried today it worked without issue. There was no change in code or configuration on our end between then and now, except that I updated expo-cli today from 3.19 to 3.20 so perhaps that fixed it.

Thanks for your prompt reply.

I’m not sure if I should start a new thread or not but we’ve been receiving this error again for the last four days. We tried building on different platforms as mentioned in the original post. We have tried a few times a day since the 16th and have not gotten one build into Apple’s system. The error has consistently been:

ERROR ITMS-90725: “SDK Version Issue. This app update was built with the iOS SDK. New apps for iPhone or iPad must be built with the iOS 13 SDK or later.”

The expo-cli version is 3.20.9, with Expo SDK 37.0.8, and Xcode 11.3.1

Not sure how to proceed, thanks in advance for any help.