error of npm installing the react native app

#1

when I use npm to install react native app, following error happens.
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-freebsd-ia32:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-freebsd-ia32@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-freebsd-x64:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-freebsd-x64@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-darwin-x64:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-darwin-x64@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-sunos-x64:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-sunos-x64@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-win32-x64:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-win32-x64@2.2.8-beta.1
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-linux-arm:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-linux-arm@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-linux-arm64:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-linux-arm64@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-win32-ia32:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-win32-ia32@2.2.8-beta.1
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-linux-ia32:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-linux-ia32@2.2.8
npm WARN optional Skipping failed optional dependency /@expo/ngrok-bin/@expo/ngrok-bin-darwin-ia32:
npm WARN notsup Not compatible with your operating system or architecture: @expo/ngrok-bin-darwin-ia32@2.2.8
Installing dependencies using npm…

npm ERR! cb() never called!
Failed to install

closed #2

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.