Error on launching android app - Animated node with tag 1 does not exist

Hi Guys, My expo app works perfectly in iOS & got published to app store as well, but the android version throws this error “Animated node with tag 1 does not exist”. Can someone please explain how to fix this?

This error is thrown immediately on launch: Animated node with tag 1 does not exist.

This is my package.json for reference

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  },
  "dependencies": {
    "@react-native-async-storage/async-storage": "^1.14.1",
    "@react-native-community/masked-view": "0.1.10",
    "@react-navigation/native": "^5.9.3",
    "@react-navigation/stack": "^5.14.3",
    "axios": "^0.21.1",
    "expo": "^40.0.1",
    "expo-notifications": "~0.8.2",
    "moment": "^2.29.1",
    "react": "^17.0.1",
    "react-native": "^0.64.0",
    "react-native-gesture-handler": "~1.8.0",
    "react-native-pager-view": "^5.1.0",
    "react-native-paper": "^4.7.2",
    "react-native-screens": "~2.15.2",
    "react-native-status-bar-height": "^2.6.0",
    "react-native-tab-view": "^3.0.0",
    "react-redux": "^7.2.2",
    "redux": "^4.0.5",
    "redux-thunk": "^2.3.0"
  },
  "devDependencies": {
    "@babel/core": "~7.9.0",
    "babel-eslint": "^10.1.0",
    "eslint": "^7.15.0",
    "eslint-config-airbnb": "^18.2.1",
    "eslint-config-prettier": "^6.15.0",
    "eslint-plugin-import": "^2.22.1",
    "eslint-plugin-jsx-a11y": "^6.4.1",
    "eslint-plugin-prettier": "^3.2.0",
    "eslint-plugin-react": "^7.21.5",
    "prettier": "^2.2.1"
  },
  "private": true
}

I have the exact same problem.

npm install https://github.com/expo/react-native/archive/sdk-39.0.4.tar.gz fixed the issue for me.

This worked for me also. Thanks for the tip!

1 Like

@vivekchand19 this totally worked, but sadly a contact at Expo told us not to use this fix, as it might break things in expo 40. Are there any other solutions?

Hi @kennis1. Are you also using SDK 40?

What does expo diagnostics output for you?

@vivekchand19 it turns out that the following are identical:

https://github.com/expo/react-native/archive/sdk-39.0.4.tar.gz
https://github.com/expo/react-native/archive/sdk-40.0.0.tar.gz

So does it still work for you if you use sdk-40.0.0.tar.gz instead?
Does it break if you use sdk-40.0.1.tar.gz?

The differences between sdk-40.0.0 and sdk-40.0.1 are as follows. Ignore the iOS changes (in the React directory):

Do you by any chance have a password field on the initial screen of your app?
Are you able to reproduce the crash with a new app or strip out most of the contents of your app to get a minimal app that still crashes with this error?