Error running 'xcrun simctrl openurl booted exp: url | Error installing or running app, Error: Process exited with a non-zero code: 60

#1

I get this error everytime I run any xpo project.
But it never hurts. so i keep going.

  1. is it ok to have this keep going in production ?
  2. How can i fix it ?
  3. why is it showing up

#2

Hey @harryp does this bug still appear when you restart XDE?

#3

yes , i just quite and restart both xde and simulator , and it did appear.

Note: I also tried quiting and restartnig and creating new project from scratch and it still throwed this error messag.

#4

I am tracking this GitHub issue for you: https://github.com/expo/xde/issues/66 where other users have had this problem.

It appears that its an iOS simulator issue (my best guess), have you tried cmmd + Q on your iOS simulator and starting a fresh one?

#5

yes, I did command Q

#6

I’m having the same issue here. Started happening yesterday when the XDE asked to update. I tryed uninstalling and downloading again, but the same error still persists. Right now the iOS and Android (genymotion) emulators do not work for me…

#7

I think the issue is solved just by updating xcode. But the error still appears on XDE console.

1 Like
#8

Glad you were able to resolve this issue via xcode update.

#9

Which version of xcode you have updated to?

1 Like
#10

I’m with version 8.3.3 here.

2 Likes
#11

Same problem here.
Xcode Version 9.4.1