Error upgrading to SDK 31


#1

I am updating to SDK 31 and keep getting this error. I tested installing each dependency individually and have determined that the problem occurs when actually upgrading expo or jest-expo. The install process just gets stuck here and does not complete.


#2

Hey @hochmanjoel,

Are you still experiencing this issue? Also, are you using yarn or npm to install?

Cheers,

Adam


#3

Yeah. I had to downgrade because I could not figure it out. I use NPM


#4

It looks like npm hangs when trying to remove an old dependency from the tree. Please make sure to delete your project’s node_modules directory before running npm install.


#5

I did that. That’s why I was so confused


#6

Alright, then I suspect it might be a bug in npm related to removing the package from package-lock.json. Are you using the latest npm? You can upgrade with npm install -g npm.

If the latest npm version still has this problem, I’d try to find and remove the whatwg-fetch dependency from package-lock.json manually or, as a last resort, remove package-lock.json altogether before running npm install (note that this may give you different package versions than you had locked in the package lock file, so you shouldn’t normally do this).


#7

Before removing package-lock.json, you could also try running npm cache verify.


#8

Ok I did all that. Messed around a little more. My CRNA entry broke (“couldn’t find babel-plugin-transform-react-jsx-source”). I reverted back again. And now my completely normal code is broken. Oy vey


closed #9

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.