Error when executing `expo login`

I’m getting the error

TypeError [ERR_HTTP_INVALID_HEADER_VALUE] [ERR_HTTP_INVALID_HEADER_VALUE]: Invalid value "undefined" for header "Exponent-Client"

when I execute expo login.

I found this thread in this forum with the same error but I specifically downgraded to the 14.16 node version and I still have the same problem.

  Expo CLI undefined environment info:
    System:
      OS: Linux 5.10 Arch Linux
      Shell: 5.8 - /bin/zsh
    Binaries:
      Node: 14.16.0 - ~/bin/node
      Yarn: 1.22.10 - /usr/bin/yarn
      npm: 7.8.0 - /usr/bin/npm
    IDEs:
      Android Studio: 4.1 AI-201.8743.12.41.7199119
    npmPackages:
      expo: ^40.0.1 => 40.0.1 
      react: ^16.14.0 => 16.14.0 
      react-dom: ^17.0.2 => 17.0.2 
      react-native: ^0.64.0 => 0.64.0 
      react-native-web: ^0.13.18 => 0.13.18 
    Expo Workflow: managed

I also tried downgrading npm but it fixed nothing. I’ll try to downgrading expo as well.

Edit again: I was able to login (finally) after downgrading expo-cli. I still can’t open the app in an Android emulator but at least I was able to login…