Error when trying to run exp publish

Cool! Thanks .

Thanks @rudineyaf, It worked for me aswell… thanks :slightly_smiling_face:

This one also worked for me.

It works for me. Thank you…

ahh thank you, removing the expo directory fixed this!

Thanks it works for me tooo!! amazing!

this works, thx

Not sure if this was your intention but to anybody else reading this, expo start -c will clear the react native packer cache while expo build:android -c or expo build:ios -c will clear your publishing credentials stored on the Expo servers meaning you will need to either retrieve them from a backup or regenerate them for any future builds.

1 Like

removed folder .expo its work, but. Still error connect ECONREFUSED 127.0.0.1:19001

Do you get any other error? Can you post the full error message?

Another thing you can try is to run expo start in one Terminal window and then run expo publish in another window.

Hey . I am also having the same issue when trying to run the cmd expo publish.

I have deleted the .expo folder , I have tried running the cmd without my firewall ,also tried running it on a different network. Also tried running it like you had said within two different terminals.

Here’s my error, my best bet is to do with something pertaining towards the asset bundles before closing expo server. Haha!

here’s the log

Unable to find an existing Expo CLI instance for this directory, starting a new one…
Starting Metro Bundler on port 19004.
Tunnel ready.
Publishing to channel ‘default’…
Building iOS bundle
Building Android bundle
Analyzing assets
Building JavaScript bundle
Uploading assets
No assets changed, skipped.
Processing asset bundle patterns:

  • C:\stonar\stonar-customer***
    Uploading JavaScript bundles
    › Closing Expo server
    read ECONNRESET
    Error: read ECONNRESET
    at TLSWrap.onStreamRead (internal/stream_base_commons.js:200:27)

Hi

Your error looks a bit different, actually. You’re getting a “Connection reset by peer” error rather than a “Connection refused” error.

It’s not clear to me exactly which connection is reset (connection to Metro? Or to the Expo server that the bundle is being published to?)

Do you get the same error every time?

It almost looks like the publish worked OK and then right at the end when the connection was closing for some reason there was a “Connection reset by peer” error.

By the way:

this implies you have something listening on port 19001 (and 19002 and 19003) already, but it seems not in the same directory. Are you by any chance running expo start for another app at the same time? That should not cause problems but might be safer if you close it first if so.

so I tried running cmd expo publish without expo start and i get the following error:
connect ECONNREFUSED 127.0.0.1:19001
Error: connect ECONNREFUSED 127.0.0.1:19001
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1134:16)

however, when i run expo start and the cli ui opens up in my browser , i press the publish button over there and then it would begin to do all the builds and replicate the error above…

I have no other apps running, so when i tried to run cmd expo publish ,i deleted the .expo folder and it ended up opening on port 19001 and fails at the end like this

Uploading JavaScript bundles
› Closing Expo server
read ECONNRESET
Error: read ECONNRESET
at TLSWrap.onStreamRead (internal/stream_base_commons.js:200:27)

HEY !! I got it work , I decided to downgrade my node version from 12.XX.XX to 10.18.1
Seems like that did the trick because i was reading the errors about something relating to node about a header being deprecated in one of the node errors

That’s strange, but I’m glad you got it working.

Thanks. Worked!) yuup))

1 Like

This worked for me ! Thank you !

1 Like

Fantastic… it’s work for me.
Tks man.

<dev_sem_fronteiras/>

1 Like

this also worked for me, thank you SO MUCH

1 Like

removing .expo worked for me too, cheers