Error While Trying To Eject Project From Expo


#1

hi guy
i tried to eject my project from expo, but i faced with this error :frowning:
can you help me?

F:\react\Departed Project\my-new-project>npm run eject

my-new-project@ eject F:\react\Departed Project\my-new-project
expo eject

This command requires Expo CLI.
Do you want to install it globally [Y/n]? Y
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! my-new-project@ eject: expo eject
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the my-new-project@ eject script.
npm ERR! This is probably not a problem with npm. There is likely additional log
ging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Designer2\AppData\Roaming\npm-cache_logs\2018-08-15T11_00
_16_676Z-debug.log


#2

Hey @mohammadhshmnd,

What type of project is it?

If it is a CRNA project, the command to eject is npm run eject.

If it is a standard expo project, the command is exp detach.
https://docs.expo.io/versions/v29.0.0/expokit/detach

Cheers,

Adam


#3

Hi @adamjnav
This is a standard expo project
i used that command (exp detach) and it gave me an android folder
now can i run my project with “react-native run-android” command?
Thanks for your help


#4

Hey,

In order to continue developing the project, you’ll still use one of our dev tools to serve the JS bundle (either exp CLI, XDE or the new devtools) and then you’ll open the project with Android Studio.

Cheers,

Adam


#5

@adamjnav thanks Adam <3


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.