Error with Expo components

#1

Hello everyone

I am new with Expo SDK’s and trying out few of the components available.

Upon downloading and importing any component from Expo, I am getting following error on the stimulator, could anyone please help me on this matter?

Regards

#2

How did you install the expo sdk?

#3

by running the following command in the project folder,

npm install expo --save

#4

Are you using the Expo client app on your phone? How did you make the project originally ? You can’t just nom install into a project that you react-native init ed bc you’re missing the native code you need.

#5

Yes I created RN project using init command and then npm install expo in the project folder.

I did try using the Expo XDE but it appears to throw following error;

Error: You are using npm version 5.3.0. Please use an npm version that is >= 3.0.0 and < 5.0.0. Run ‘npm i -g npm@4.6.1’ to resolve.

#6

Yeah npm5 is still very buggy. Just follow those instructions.