Error: write EPROTO 4379422144:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:

Facing this error:
› Waiting on exp://192.168.1.3:19000

› Scan the QR code above with Expo Go (Android) or the Camera app (iOS)

› Press a │ open Android

› Press i │ open iOS simulator

› Press w │ open web

› Press d │ show developer tools

shift+d │ toggle auto opening developer tools on startup ( enabled )

› Press ? │ show all commands

Logs for your project will appear below. Press Ctrl+C to exit.

Opening exp://192.168.1.3:19000 on Pixel_4_API_30


Error: write EPROTO 4379422144:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:
at WriteWrap.onWriteComplete [as oncomplete] (internal/stream_base_commons.js:94:16)
┌─────────────────────────────────────────────────────────────────────────┐
│                                                                         │
│   There is a new version of expo-cli available (4.3.4).                 │
│   You are currently using expo-cli 4.3.2                                │
│   Install expo-cli globally using the package manager of your choice;   │
│   for example: `npm install -g expo-cli` to get the latest version      │
│                                                                         │
└─────────────────────────────────────────────────────────────────────────┘

  Expo CLI 4.3.2 environment info:
    System:
      OS: macOS 10.15.6
      Shell: 5.7.1 - /bin/zsh
    Binaries:
      Node: 12.20.0 - ~/.nvm/versions/node/v12.20.0/bin/node
      npm: 6.14.8 - ~/.nvm/versions/node/v12.20.0/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    Managers:
      CocoaPods: 1.10.1 - /usr/local/bin/pod
    SDKs:
      iOS SDK:
        Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
    IDEs:
      Android Studio: 4.1 AI-201.8743.12.41.7199119
      Xcode: 12.4/12D4e - /usr/bin/xcodebuild
    npmPackages:
      expo: ~40.0.0 => 40.0.1 
      react: 16.13.1 => 16.13.1 
      react-dom: 16.13.1 => 16.13.1 
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2 
      react-native-web: ~0.13.12 => 0.13.18 
    npmGlobalPackages:
      expo-cli: 4.3.2
    Expo Workflow: managed

expo diagnostics is showing this

Please run expo diagnostics and paste the log that’s printed out along with your question or issue!

Hey @abankitbaid, does this occur when opening the project no matter what or only when trying via an Android emulator?

Cheers,
Adam

@adamjnav
yes, if i am opening the project in an emulator or mobile too using expo go its showing this error in terminal and showing screen in mobile like

Something went wrong Could not load exp://192.168.1.3:19000

Need help

Actually, there was a proxy set up on my system so now it is working now.
If someone is also facing this problem, follow these steps:

  1. Navigate to the Apple menu > System Preferences, and click Network .
  2. Select the network service you use from the list (e.g., Ethernet or Wi-Fi).
  3. Click Advanced, then click Proxies.
  4. If nothing is checked under " Select a protocol to configure", unselect eveything if something is selected.

and for me expo started working after that.