exp build:ios -e -c failed -- `build_failure!': [!] Error packaging up the application (FastlaneCore::Interface::FastlaneBuildFailure)


#1

Hi, I use command exp build:ios -e -c to build ios ipa file.
But I get the error as follow and I don’t known what it mean.
Please help. Thanks.

PS: I use the same upload files and build successful last week, but it failed today.

generating IPA...
[stderr] /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/interface.rb:163:in `build_failure!': [!] Error packaging up the application (FastlaneCore::Interface::FastlaneBuildFailure)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in `method_missing'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/error_handler.rb:112:in `handle_package_error'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:121:in `block in package_app'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/command_executor.rb:93:in `execute'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:117:in `package_app'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:27:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/manager.rb:19:in `work'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:44:in `block (2 levels) in run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in `run_active_command'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:75:in `run!'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in `run!'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:75:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:15:in `start'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane/lib/fastlane/cli_tools_distributor.rb:100:in `take_off'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/bin/fastlane:20:in `<top (required)>'
[stderr] 	from /usr/local/bin/fastlane:23:in `load'
[stderr] 	from /usr/local/bin/fastlane:23:in `<main>'
[stderr] [01:41:31] 'ios:build-and-sign-ipa' errored after 4.33 min
[stderr] [01:41:31] Error: Process exited with non-zero code: 1
[stderr]     at ChildProcess.child.on (/usr/local/turtle-agent/tools-public/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
[stderr]     at emitTwo (events.js:125:13)
[stderr]     at ChildProcess.emit (events.js:213:7)
[stderr]     at maybeClose (internal/child_process.js:927:16)
[stderr]     at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

My build id is: 93b45e87-e83b-4c2a-b3c5-d3a8f2b304c3
My env:

Environment:
  OS: macOS High Sierra 10.13.2
  Node: 8.9.0
  Yarn: 1.5.1
  npm: 5.5.1
  Watchman: 4.9.0
  Xcode: Xcode 9.2 Build version 9C40b
  Android Studio: 2.3 AI-162.4069837

Packages: (wanted => installed)
  expo: ^26.0.0 => 26.0.0
  react: 16.2.0 => 16.2.0
  react-native: https://github.com/expo/react-native/archive/sdk-26.0.0.tar.gz => 0.54.2

#2

I’m also getting the same error with both 27 and 28.

One of the builds: https://expo.io/builds/a625f96e-f419-46b5-8f09-77af094b4ccb

I’ve tried clearing the certificates and provisioning profile, and re-adding them and it made no difference.


#3

I am seeing issues with this also.

React: 16.3.1
expo: 27.0

An example build is at https://expo.io/builds/00347873-1ffd-4692-b30a-18ae56210420


#4

Same problem:

React: 16.3.1
expo: 27.0

example: https://expo.io/builds/eeb81807-6797-482a-b906-7b57ae4abd82


#5

Same problem:

react: 16.3.1
expo: 27.0.2

example: https://expo.io/builds/1d65c240-3634-428d-bdf8-407ce9d21764


#6

Same issue here as well, but without using the -c option

react: 16.3.1
expo: 28.0.0

example: https://expo.io/builds/91118cca-7bbe-4109-a732-114fcc25e865


#7

This is still failing for me today, but is now showing a lot more logging before the error

INFO [2018-06-15 07:55:44.40]: $ /usr/bin/xcrun /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/assets/wrap_xcodebuild/xcbuild-safe.sh -exportArchive -exportOptionsPlist '/var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/gym_config20180615-8514-11hrh55.plist' -archivePath /private/tmp/turtle/10e39b2a-3441-4dcb-876b-f1fa2d53864e/archive.xcarchive -exportPath '/var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/gym_output20180615-8514-1cbfctk' OTHER_CODE_SIGN_FLAGS="--keychain /private/tmp/xdl/1739f440-70ac-11e8-97e5-6b4436e6b646.keychain" 
INFO [2018-06-15 07:55:44.42]: ▸ + xcodebuild -exportArchive -exportOptionsPlist /var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/gym_config20180615-8514-11hrh55.plist -archivePath /private/tmp/turtle/10e39b2a-3441-4dcb-876b-f1fa2d53864e/archive.xcarchive -exportPath /var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/gym_output20180615-8514-1cbfctk 'OTHER_CODE_SIGN_FLAGS=--keychain /private/tmp/xdl/1739f440-70ac-11e8-97e5-6b4436e6b646.keychain'
INFO [2018-06-15 07:55:45.01]: ▸ 2018-06-15 07:55:45.016 xcodebuild[8543:92167] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path '/var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/ExpoKitApp_2018-06-15_07-55-45.014.xcdistributionlogs'.
INFO [2018-06-15 07:57:02.02]: ▸ /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/assets/wrap_xcodebuild/xcbuild-safe.sh: line 61:  8543 Segmentation fault: 11  xcodebuild "$@"
[stderr] [07:57:02] 'ios:build-and-sign-ipa' errored after 1.43 min
[stderr] [07:57:02] Error: Process exited with non-zero code: 1
+ xcodebuild -exportArchive -exportOptionsPlist /var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/gym_config20180615-8514-11hrh55.plist -archivePath /private/tmp/turtle/10e39b2a-3441-4dcb-876b-f1fa2d53864e/archive.xcarchive -exportPath /var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/gym_output20180615-8514-1cbfctk 'OTHER_CODE_SIGN_FLAGS=--keychain /private/tmp/xdl/1739f440-70ac-11e8-97e5-6b4436e6b646.keychain'
[stderr]     at ChildProcess.child.on (/usr/local/turtle-agent/tools-public/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
[stderr]     at emitTwo (events.js:125:13)
2018-06-15 07:55:45.016 xcodebuild[8543:92167] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path '/var/folders/8s/t4vscjs14yd6p8736s7b3wyc0000gn/T/ExpoKitApp_2018-06-15_07-55-45.014.xcdistributionlogs'.
[stderr]     at ChildProcess.emit (events.js:213:7)
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/assets/wrap_xcodebuild/xcbuild-safe.sh: line 61:  8543 Segmentation fault: 11  xcodebuild "$@"
[stderr]     at maybeClose (internal/child_process.js:927:16)
ERROR [2018-06-15 07:57:02.02]: Exit status: 139
[stderr]     at Socket.stream.socket.on (internal/child_process.js:348:11)
+---------------+-------------------------+
[stderr]     at emitOne (events.js:115:13)
|            Build environment            |
[stderr]     at Socket.emit (events.js:210:7)
+---------------+-------------------------+
[stderr]     at Pipe._handle.close [as _onclose] (net.js:545:12)
| xcode_path    | /Applications/Xcode.app |
| gym_version   | 2.95.0                  |
| export_method | enterprise              |
| sdk           | iPhoneOS11.0.sdk        |
+---------------+-------------------------+
INFO [2018-06-15 07:57:02.06]: 
ERROR [2018-06-15 07:57:02.06]: Looks like fastlane ran into a build/archive error with your project
ERROR [2018-06-15 07:57:02.06]: It's hard to tell what's causing the error, so we wrote some guides on how
ERROR [2018-06-15 07:57:02.06]: to troubleshoot build and signing issues: https://docs.fastlane.tools/codesigning/getting-started/
ERROR [2018-06-15 07:57:02.06]: Before submitting an issue on GitHub, please follow the guide above and make
ERROR [2018-06-15 07:57:02.06]: sure your project is set up correctly.
ERROR [2018-06-15 07:57:02.06]: fastlane uses `xcodebuild` commands to generate your binary, you can see the
ERROR [2018-06-15 07:57:02.06]: the full commands printed out in yellow in the above log.
ERROR [2018-06-15 07:57:02.06]: Make sure to inspect the output above, as usually you'll find more error information there
INFO [2018-06-15 07:57:02.06]: 
[stderr] /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/interface.rb:163:in `build_failure!': [!] Error packaging up the application (FastlaneCore::Interface::FastlaneBuildFailure)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in `method_missing'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/error_handler.rb:112:in `handle_package_error'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:121:in `block in package_app'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/command_executor.rb:93:in `execute'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:117:in `package_app'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:27:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/manager.rb:19:in `work'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:44:in `block (2 levels) in run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in `run_active_command'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:75:in `run!'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in `run!'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:75:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:15:in `start'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane/lib/fastlane/cli_tools_distributor.rb:100:in `take_off'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/bin/fastlane:20:in `<top (required)>'
[stderr] 	from /usr/local/bin/fastlane:23:in `load'
[stderr] 	from /usr/local/bin/fastlane:23:in `<main>'
unable to build and sign IPA

#8

I got the same error as well? Is this happen for everyone? I am using my own certs for building.


#9

It is still happening for me as well. I am also providing my own certs.


#10

Ok for me apparently is because of the ad hoc cert. As exp is currently not supporting ad hoc build.


#11

My certs are in house (enterprise), but not ad hoc. The latest attempt to build gives a lot more information, but the primary error is the same: “method missing” in fastlane.

This is also in the output, if it is any help. Note the “Couldn’t automatically detect the provisioning profile mapping” part:

building and signing IPA
[04:52:13] Using gulpfile /usr/local/turtle-agent/tools-public/gulpfile.js
[04:52:13] Starting 'ios:build-and-sign-ipa'...
provisioning profile copied to home directory
done retrieving provisioning profile data
checking if teamID is present in keychain and that certificate is valid...
ensured certificate is valid
validating provisioning profile...
provisioning profile is valid
writing export-options.plist file...
created export-options.plist file
generating IPA...
[04:52:14]: e[33mGet started using a Gemfile for fastlane https://docs.fastlane.tools/getting-started/ios/setup/#use-a-gemfilee[0m
INFO [2018-06-16 04:52:14.78]: $ xcodebuild -showBuildSettings -workspace /usr/local/turtle-agent/shellAppWorkspaces/ios/default/ExpoKitApp.xcworkspace -scheme ExpoKitApp
WARN [2018-06-16 04:52:17.81]: Command timed out after 3 seconds on try 1 of 4, trying again with a 6 second timeout...
ERROR [2018-06-16 04:52:22.08]: Couldn't automatically detect the provisioning profile mapping
ERROR [2018-06-16 04:52:22.08]: Since Xcode 9 you need to provide an explicit mapping of what
ERROR [2018-06-16 04:52:22.08]: provisioning profile to use for each target of your app
ERROR [2018-06-16 04:52:22.08]: no implicit conversion of Symbol into Integer
DEBUG [2018-06-16 04:52:22.08]: /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/detect_values.rb:78:in `[]'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/detect_values.rb:78:in `detect_selected_provisioning_profiles'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/detect_values.rb:31:in `set_additional_default_values'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/module.rb:15:in `config='
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/manager.rb:8:in `work'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:44:in `block (2 levels) in run'
/usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
/usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in `run'
/usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in `run_active_command'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:75:in `run!'
/usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in `run!'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:75:in `run'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:15:in `start'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane/lib/fastlane/cli_tools_distributor.rb:100:in `take_off'
/usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/bin/fastlane:20:in `<top (required)>'
/usr/local/bin/fastlane:23:in `load'
/usr/local/bin/fastlane:23:in `<main>'

#12

Still failing today. I’m also using enterprise certificates (not ad-hoc).


#13

Are people able to build iOS apps at all? I am just not sure what the root problem is. I assume you need certificates to be able to build the app, so I assume this is happening for all?


#14

I finally just detached to debug the build problem on my own computer. It turned out I had an error when I built it on my own, which led me to discover the cause of the issue for me: iCloud integration.

In https://developer.apple.com/account/ios/identifier/bundle I clicked on my App ID, selected “Edit”, then
I changed the iCloud compatibility to “Include CloudKit support (requires Xcode 6)” instead of “Compatible with Xcode 5” and it worked. I haven’t tried to build on expo’s process since, but I hope that this might help you guys.


#15

I am wondering if the issue could be related to (and I am totally making stuff up…) that the Expo internal build process has upgraded to xcodebuild version 9. it seems to explicitly require a mapping to a provisioning file. Maybe the Fastlane build process hasn’t been updated for this after recent upgrade?

https://docs.fastlane.tools/codesigning/xcode-project/#xcode-9-and-up


#16

This is still failing. I don’t think it’s to do with iCloud as my certs don’t have any iCloud settings enabled.

@jptacek I think you’re correct, but I don’t think there’s anything we can do about it as it’s on the Expo side (it’d be nice to get some acknowledgement about this issue from Expo themselves).

At this rate I might have to eject and manage my own builds (as much as I don’t want to lose the convenience of Expo).


#17

Well, that’s good to know. Managing the builds myself hasn’t been difficult at all. In some ways, it is easier. You still have the benefit of publishing updates through expo, since your application still uses the JS bundle from their servers. Make sure after you detach that you do exp publish before you try to build in Xcode.