exp errors following expo upgrade

#1

I am upgrading from SDK 26 to 27. I have followed the instructions at…

I now get this error when I run exp start:

[10:12:30] Error: Problems validating fields in app.json. See https://docs.expo.io/versions/v27.0.0/guides/configuration.html.
[10:12:30] • should NOT have additional property ‘ios.publishBundlePath’.
[10:12:30] • should NOT have additional property ‘ios.publishManifestPath’.

As you can see, the error seems to refer to the new keys we’re instructed to add to app.json at https://gist.github.com/janicduplessis/30ec95451733d34ffcf7d5cb27ba0e28

My exp version: 55.0.5.

I intend to upgrade to SDK 28, but the docs recommend against skipping major versions, so I’m upgrading to SDK 27 first.

#2

I have worked around this by rolling back to 26, un-detaching, upgrading to 28, then detaching to ExpoKit again.

This I believe is an unrelated issue, but had the same solution: Simulator says I need a newer version of Expo Client -- but am I even using the Expo Client if I have detached to ExpoKit?

closed #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.