Exp start doesnt work

#1

currently i am working on project wich uses expo 20 version
after i run npm install and exp start i got some error
here is the screenshot of the error

and here is my package .json file content

{
   ...
    "dependencies": {
        "expo": "^20.0.0",
        "firebase": "^4.0.0",
        "html-entities": "^1.2.1",
        "i18next": "^8.4.0",
        "immutable": "^3.8.1",
        "jwt-decode": "^2.1.0",
        "numeral": "^2.0.5",
        "react": "16.0.0-alpha.12",
        "react-i18next": "^4.1.0",
        "react-native": "https://github.com/expo/react-native/archive/sdk-20.0.0.tar.gz",
        "react-native-animatable": "^1.2.0",
        "react-native-app-intro": "git+https://github.com/firdausious/react-native-app-intro.git#master",
        "react-native-communications": "^2.2.1",
        "react-native-elements": "0.13.0",
        "react-native-modal": "^2.4.0",
        "react-native-panel": "^1.0.3",
        "react-native-popup-menu": "^0.7.5",
        "react-native-router-flux": "3.40.1",
        "react-native-snackbar-dialog": "^1.3.0",
        "react-native-swipeable-parallax-carousel": "^1.1.0",
        "react-redux": "^5.0.1",
        "redux": "^3.6.0",
        "redux-form": "^6.5.0",
        "redux-logger": "^2.7.0",
        "redux-thunk": "^2.1.0",
        "reselect": "^2.5.4",
        "sentry-expo": "~1.6.0",
        "validator": "^7.0.0"
    },
    "devDependencies": {
        "babel-core": "^6.17.0",
        "babel-eslint": "^7.1.1",
        "babel-jest": "19.0.0",
        "babel-preset-es2015": "^6.18.0",
        "babel-preset-expo": "^4.0.0",
        "babel-register": "^6.16.3",
        "eslint": "^3.9.1",
        "eslint-config-airbnb": "^14.0.0",
        "eslint-plugin-import": "^2.2.0",
        "eslint-plugin-jsx-a11y": "^4.0.0",
        "eslint-plugin-react": "^6.4.1",
        "jest-expo": "~20.0.0",
        "pre-commit": "^1.2.2"
    }
}
#2

hey, seems like some issue with installing dependencies. are you using npm 4.6.1?

i would try removing all your node modules, clear your npm cache, and then try using yarn install instead of npm install. if that’s not the issue then in might be a wrong path in one of our dependencies when its trying to install a module

#3

anyone else had this problem? And if so how did you fix it?

Thank you for your time.

#4

Samee’s diagnosis looks right. Have you tried dropping node_modules and reinstalling?

#5

i have tried samee’s suggestion and still doesnt work with same error
im using npm version 5.5.1

It worked again if i upgrade to sdkVersion 21.0.0
I still dont undrestand why, but i guess i have to upgrade it then