expo build:ios : Cannot find module '@expo/traveling-fastlane-darwin'


#1

I am trying to publish my app for iOS using expo build:ios command. But it is giving me error
"Cannot find module ‘@expo/traveling-fastlane-darwin’
[15:09:08] Set EXPO_DEBUG=true in your env to view the stack trace. "

I have tried reinstalling expo-cli, and also installing traveling fastlane by itself by running “npm i @expo/traveling-fastlane-darwin”.
Inside the node_modules @expo folder, traveling-fastlane-darwin exists as well, but I am still getting this error.

Does anyone know how to fix it?


#2

Hey @junaidchaudry,

I’ll investigate this internally but also wanted to make sure that you know you can run expo publish to publish a new JS bundle and assets. You don’t have to build to do so. If you upgraded or made some changes in your app.json then you would have to build a new .ipa. You can read more about this here: https://docs.expo.io/versions/v31.0.0/workflow/publishing#limitations

Cheers,

Adam


#3

Hi,
Thank you for the reply and looking into the matter. I am actually trying to create an .ipa file. Earlier I created the apk file for my app and that worked completely fine, but build:ios is giving me error even though the folder does exist

Thanks,


#4

exp build:ios requires a Mac — “darwin” refers to macOS. Could it be you are running the command on another platform?


#5

I am actually using a Mac OS High Sierra


#6

I’ve got something similar after upgrading to the latest SDK.

In my CI environment, i use

npm ci

And my build is failing. I recreated using npm ci locally, and received the following:

/Users/chris/Coding/mobile/node_modules/@expo/traveling-fastlane-linux/platform.js:3
  throw new Error('Not running on platform with Linux available');
  ^

Error: Not running on platform with Linux available
    at Object.<anonymous> (/Users/chris/Coding/mobile/node_modules/@expo/traveling-fastlane-linux/platform.js:3:9)
    at Module._compile (internal/modules/cjs/loader.js:689:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:700:10)
    at Module.load (internal/modules/cjs/loader.js:599:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
    at Function.Module._load (internal/modules/cjs/loader.js:530:3)
    at Function.Module.runMain (internal/modules/cjs/loader.js:742:12)
    at startup (internal/bootstrap/node.js:279:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:752:3)

> @expo/traveling-fastlane-darwin@1.6.1 preinstall /Users/chris/Coding/mobile/node_modules/@expo/traveling-fastlane-darwin
> node platform.js

My CI server is linux, and locally I’m on a Mac.

Locally, if I use npm install everything works as expected.


#7

has anyone found any solution to the problem?
Below is how I am trying to run the build. I am using a MAC OS High Sierra 10.13.6

expo build:ios
[12:10:57] Making sure project is set up correctly...
[12:10:58] Your project looks good!
[12:10:58] Cannot find module '@expo/traveling-fastlane-darwin'
[12:10:58] Set EXPO_DEBUG=true in your env to view the stack trace.