expo build:ios on Linux(ubuntu)

Long story short, is one able to expo bundle:ios successfully on an ubuntu machine? I’ve not been able to do so and have given up on it(im using a 2011 macbook to build:ios).

I’d love to hear from anyone who develops with a Linux machine and has been able to expo build:ios,

Thanks.

I assume that by expo bundle:ios you meant expo build:ios, in that case system shouldn’t matter, builds are happening remotely either way. You need a mac to upload IPA to app store, but building should work everywhere.

Thanks for the reply, I greatly appreciate it.

I was recently trying to build:ios (not bundle as you noted) on my Ubuntu 18.04 machine and I wasn’t able to create an IPA that was acceptable to Transporter. (error ITMS 90956)

I managed to work around the issue by installing an compatible version of Xcode on a 2011 Macbook I had lying around, and doing the same build:ios I was now able to send the IPA through Transporter.

As a note, I was not successful using the Macbook until I downloaded Xcode, this prompted my question here on the forums.

I massively appreciate any more input, thanks.

Did you try to upload that older (not working IPA) after upgrade? My guess would be that problem was with uploading and update of xcode or transporter fixed the issue. expo build:ios command is not affected in any way by you local environment, only part done locally is bundling js and assets.

Hmm, I didn’t try to re-upload the same file. I was aware at the time that the build process was done independently of my personal machine, however I just gave it a shot and it worked.

-> I tried building on my iOS machine, unsuccessful w/ the Transporter.
-> Downloaded Xcode, built the bundle (aware of the fact that it shouldn’t matter)
-> expo build:ios
-> new bundle was successful w/ Transporter

It could have been just a weird error, I appreciate your comments to help me investigate.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.